Bug 102220 - creating a .idl directory causes rhn-applet-gui to use 99% cpu
creating a .idl directory causes rhn-applet-gui to use 99% cpu
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-12 14:37 EDT by Tony Hoffmann
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-12 20:01:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tony Hoffmann 2003-08-12 14:37:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
If a directory named .idl exists in the users home directory
the rhn-applet-gui will hang when started using 99% cpu.  I
also note that logout no longer will function on a gnome desktop.

RH 7.3 seems not to exhibit these problems.

Version-Release number of selected component (if applicable):
rhn-applet-2.0.9-8.0.1

How reproducible:
Always

Steps to Reproduce:
1.On a RH 8.0 system create a .idl directory in home directory
2.Log into Gnome desktop
3.That's it.  Check top.  rhn-applet-gui using 99%.  Logout in
gnome menu unresponsive.
    

Additional info:
Comment 1 Daniel Veillard 2003-08-12 18:43:42 EDT
I did exactly this on a Red Hat 9 system, created the ~/.idl directory,
exited my applet, restarted rhn-applet-gui, appeared fine, asked to check
for updates, worked fine, the applet doesn't show on top and seems to
behave correctly.
So to me the bug seems fixed in Red Hat 9 or I can't reproduce it.

Daniel
Comment 2 Tony Hoffmann 2003-08-12 19:33:28 EDT
Gee, December must of come early.  I agree that this is a bug in 8.0.  Aren't
you still supporting that version?  Shouldn't you try the problem on 8?  Why 
close the report!  It's still a bug as far as I'm concerned.  Upgrading to 9 is
not an option for me.  I discovered this problem after upgrading my version
of IDL from Research Systems to the latest version (6.0).  It creates an .idl
dir to keep config info in.  RSI has confirmed the problem on 8.0.
Comment 3 Daniel Veillard 2003-08-12 20:01:16 EDT
The rhn-applet uses ORBit to do CORBA calls to the panel. This is likely
to be the cause of the problem. So ORBit or one of the CORBA packages
used like bonobo and bonobo-ui coming from the GNOME project shipped with
Red Hat migh be interfering with your software package. This software package
doesn't seems to be part of the Red Hat distribution. So we had no way
to test the problem, right ? The problem seems fixed in the new version
of GNOME, so I suggest you upgrade. 

If you can't upgrade and are using an external package which does not support
Red Hat 8.0 , there isn't much I can do. Seems you made a mistake of not
checking first that the external software package wasn't supported on 8.0 .
Rebuilding ORBit version from Red Hat 9 on your system and upgrading with it
might fix the problem, but I can't make any garantee about this working
or being safe.

 My reaction is that it seems fixed in the current release of the Red Hat
release, and I feel it is correct to close the bug as such.

Daniel

Note You need to log in before you can comment on or make changes to this bug.