Bug 1022200 - yum --color=always Nonfunctional
yum --color=always Nonfunctional
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 12:59 EDT by quantumn
Modified: 2013-10-30 04:54 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Fedora 19
Last Closed: 2013-10-30 04:54:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example of yaourt output (350.85 KB, image/png)
2013-10-22 13:02 EDT, quantumn
no flags Details

  None (edit)
Description quantumn 2013-10-22 12:59:32 EDT
Description of problem:
When using yum --color=always search {package} ... no color results.


Version-Release number of selected component (if applicable):
yum 3.4.3

How reproducible:
always

Steps to Reproduce:
1. yum --color=always search {package}
2.
3.

Actual results:
White text, not color

Expected results:
Color results

Additional info:

Also when doing a search yum does not indicate which of the packages listed, are already installed.  Attached please find a snap of Arch's yaourt.
Comment 1 quantumn 2013-10-22 13:02:38 EDT
Created attachment 815100 [details]
Example of yaourt output
Comment 2 Zdeněk Pavlas 2013-10-23 04:20:30 EDT
yum search does no coloring, it just highlights (bold) the string you searched for. "yum list" should produce some color output. (installed/downloaded/newer-than-installed/older-than-installed should all be printed in different colors).

These colors are customizable (man yum.conf, color_list_* options). Does "yum list" work on your system as expected?
Comment 3 quantumn 2013-10-23 12:00:50 EDT
Surely this isn't correct as if only applicable to list it would be 
# yum --color=list list

Anyway I have no color even in list, nor is there any indication of whether the respective packages are installed or not.
Comment 4 Zdeněk Pavlas 2013-10-24 06:53:02 EDT
> # yum --color=list list

No, the --color option is global. Normally when output is redirected (eg with "|grep ...") you want to turn colors off. With --color=always it should be still on.

> Anyway I have no color even in list,

It works for me.. Upgrades are blue, downgrades are cyan, etc.. Maybe you didn't have any upgrades/downgrades available?  Does the following work?

# echo color_list_installed_reinstall=red >>/etc/yum.conf
# yum info yum

Loaded plugins: ...
Installed Packages
Name        : yum
              ^^^^ should be in red
Repo        : installed
Comment 5 quantumn 2013-10-28 11:52:06 EDT
OK, Fedora is just too painful to set up, in too many ways.

I'm out of here.

Note You need to log in before you can comment on or make changes to this bug.