Bug 1022238 - need install proj-epsg
need install proj-epsg
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pyproj (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Jos de Kloe
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 15:40 EDT by Vojtěch Kalčík
Modified: 2014-01-28 22:11 EST (History)
1 user (show)

See Also:
Fixed In Version: pyproj-1.9.2-8.20120712svn300.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-19 22:02:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vojtěch Kalčík 2013-10-22 15:40:01 EDT
Description of problem:
For load projection by epsg code is needed install proj-epsg. Mybe is missing requirment of package.

Version-Release number of selected component (if applicable):
python3-pyproj-1.9.2-6.20120712svn300.fc19.x86_64

How reproducible:
in python code

Steps to Reproduce:
1.run python code:

import pyproj
p=pyproj.Proj(init="epsg:4326")

Actual results:

Traceback (innermost last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python3.3/site-packages/pyproj/__init__.py", line 344, in __new__
    return _proj.Proj.__new__(self, projstring)
  File "_proj.pyx", line 69, in _proj.Proj.__cinit__ (_proj.c:877)
RuntimeError: b'no system list, errno: 2\n'

Expected results:


Additional info:
Comment 1 Jos de Kloe 2013-10-26 04:44:18 EDT
Thanks for pointing this out.

In principle proj-epsg is an optional extension to the proj package, so I hesitate to make it a requirement for pyproj.

On the other hand, the error you get certainly is not very pretty, but cannot be considered to be a bug in pyproj, because upstream cannot be expected to take splitting of the proj software into different subpackages in Fedora into account.

Since other subpackages of proj, like proj-nad are already listed as requirement, I think following the pragmatic approach is best, so I will add this requirement in my next update.

Meanwhile, having mentioned the solution of manually adding the proj-epsg package should provide a good workaround for others encountering the same problem.
Comment 2 Fedora Update System 2014-01-11 10:21:39 EST
pyproj-1.9.2-8.20120712svn300.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pyproj-1.9.2-8.20120712svn300.fc19
Comment 3 Fedora Update System 2014-01-12 00:06:13 EST
Package pyproj-1.9.2-8.20120712svn300.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pyproj-1.9.2-8.20120712svn300.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0697/pyproj-1.9.2-8.20120712svn300.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2014-01-19 05:38:36 EST
pyproj-1.9.2-8.20120712svn300.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/pyproj-1.9.2-8.20120712svn300.fc20
Comment 5 Fedora Update System 2014-01-19 22:02:01 EST
pyproj-1.9.2-8.20120712svn300.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2014-01-28 22:11:33 EST
pyproj-1.9.2-8.20120712svn300.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.