Bug 1022249 - Generate source jar for org.osgi.compendium
Generate source jar for org.osgi.compendium
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Maven Repository (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ER7
: EAP 6.2.0
Assigned To: Paul Gier
Nikoleta Ziakova
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 16:19 EDT by Paul Gier
Modified: 2013-12-15 11:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:21:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Gier 2013-10-22 16:19:40 EDT
The current build of org.osgi.compendium does not include a source jar.  Configuration should be added to the build to generate this file and deploy it to the Maven repo.
Comment 1 Paul Gier 2013-10-22 16:25:32 EDT
Looks like the source jar is already available in the -redhat-4 build.  The osgi compendium jar just wasn't updated in the maven repo with the other osgi jars.
https://brewweb.devel.redhat.com/buildinfo?buildID=295555
Comment 2 Paul Gier 2013-10-22 16:27:40 EDT
Updated manual includes list to new version of osgi.compendium:
http://git.app.eng.bos.redhat.com/jboss-eap/maven-repository-testsuite.git/commit/?id=bc6131ee2c3f4d0d3764f366788409458e1ad031
Comment 3 Nikoleta Ziakova 2013-10-31 08:06:09 EDT
Verified for EAP 6.2.0 ER7

Note You need to log in before you can comment on or make changes to this bug.