Bug 1022261 - Make 'iasl' for 390x and ppc64 available from Beaker's repositories
Make 'iasl' for 390x and ppc64 available from Beaker's repositories
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: inventory (Show other bugs)
develop
s390x Unspecified
unspecified Severity unspecified (vote)
: 0.14.2
: ---
Assigned To: Amit Saha
Nick Coghlan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 16:53 EDT by andrew
Modified: 2015-07-26 18:15 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 20:47:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description andrew 2013-10-22 16:53:44 EDT
Description of problem:
When inventory scripts are run on s390x hosts they fail

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Run inventory script on s390x
2.
3.

Actual results:  script fails


Expected results: script not to fail


Additional info:
The reason why this is failing is that beaker-system-scan requires Intel ASL compiler/decompiler package. And It can not find that package to install.
Comment 2 Amit Saha 2013-10-22 19:18:22 EDT
Yes, it is the same on ppc64 as well. I am currently working with release engineering to see how we can get it there.
Comment 3 Amit Saha 2013-10-28 22:13:57 EDT
Note that we support running the inventory task only on RHEL 6 at the moment:

http://gerrit.beaker-project.org/#/c/2424/
Comment 6 andrew 2013-10-29 14:00:58 EDT
This also effects ia64 
--> Missing Dependency: iasl is needed by package beaker-system-scan-1.2-3.el5.ia64 (beaker-harness)
Comment 7 Amit Saha 2013-10-29 20:40:20 EDT
(In reply to andrew from comment #6)
> This also effects ia64 
> --> Missing Dependency: iasl is needed by package
> beaker-system-scan-1.2-3.el5.ia64 (beaker-harness)

We currently support running the inventory job only on RHEL 6 for which there is no support for ia64.
Comment 11 Nick Coghlan 2013-11-06 20:47:28 EST
Closing as addressed in Beaker 0.14.2.
Comment 12 andrew 2013-11-12 08:43:30 EST
(In reply to Nick Coghlan from comment #11)
> Closing as addressed in Beaker 0.14.2.

This is still not working
https://beaker.engineering.redhat.com/jobs/540708

Loaded plugins: product-id, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package beaker-system-scan.s390x 0:1.2-3.el5 set to be updated
--> Processing Dependency: smolt for package: beaker-system-scan
--> Processing Dependency: python-linux-procfs for package: beaker-system-scan
--> Processing Dependency: python-ctypes for package: beaker-system-scan
--> Processing Dependency: iasl for package: beaker-system-scan
--> Running transaction check
---> Package beaker-system-scan.s390x 0:1.2-3.el5 set to be updated
--> Processing Dependency: iasl for package: beaker-system-scan
---> Package python-ctypes.s390x 0:1.0.2-3.el5 set to be updated
---> Package python-linux-procfs.noarch 0:0.4.5-2.el5 set to be updated
---> Package smolt.noarch 0:1.4-2.4.el5 set to be updated
--> Finished Dependency Resolution
beaker-system-scan-1.2-3.el5.s390x from beaker-harness has depsolving problems
  --> Missing Dependency: iasl is needed by package beaker-system-scan-1.2-3.el5.s390x (beaker-harness)
Error: Missing Dependency: iasl is needed by package beaker-system-scan-1.2-3.el5.s390x (beaker-harness)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
:: [   FAIL   ] :: Running 'yum -y install beaker-system-scan' (Expected 0, got 1)
Comment 13 Dan Callaghan 2013-11-12 16:36:31 EST
(In reply to andrew from comment #12)
> (In reply to Nick Coghlan from comment #11)
> > Closing as addressed in Beaker 0.14.2.
> 
> This is still not working
> https://beaker.engineering.redhat.com/jobs/540708

Can you use RHEL6 for the inventory job instead? We expect inventory to run on RHEL6 for every arch except ia64 where RHEL6 isn't supported.

On the other hand, the iasl dependency should probably be conditional on x86_64 only, since that's the only arch where it's needed, and that would avoid all these issues...
Comment 14 Amit Saha 2013-11-12 21:01:40 EST
(In reply to Dan Callaghan from comment #13)
> (In reply to andrew from comment #12)
> > (In reply to Nick Coghlan from comment #11)
> > > Closing as addressed in Beaker 0.14.2.
> > 
> > This is still not working
> > https://beaker.engineering.redhat.com/jobs/540708
> 
> Can you use RHEL6 for the inventory job instead? We expect inventory to run
> on RHEL6 for every arch except ia64 where RHEL6 isn't supported.
> 
> On the other hand, the iasl dependency should probably be conditional on
> x86_64 only, since that's the only arch where it's needed, and that would
> avoid all these issues...

Will this fix it? http://gerrit.beaker-project.org/#/c/2481/1

Note You need to log in before you can comment on or make changes to this bug.