Bug 1022301 - snapshot-create-as --disk-only is not support with glusterfs volume
snapshot-create-as --disk-only is not support with glusterfs volume
Status: CLOSED DUPLICATE of bug 1017289
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.5
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Libvirt Maintainers
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 22:18 EDT by chhu
Modified: 2013-10-23 00:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-23 00:30:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chhu 2013-10-22 22:18:24 EDT
Description of problem:
snapshot-create-as --disk-only is not support with glusterfs volume.

Version-Release number of selected component:
libvirt-0.10.2-29.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.414.el6.x86_64
qemu-img-rhev-0.12.1.2-2.414.el6.x86_64

How reproducible:
100%

Steps:
1. start a guest with glusterfs volume
# virsh dumpxml r6-qcow2|grep disk -A 6
    <disk type='network' device='disk'>
      <driver name='qemu' type='qcow2'/>
      <source protocol='gluster' name='gluster-vol1/redhat6-qcow2.img'>
        <host name='10.66.82.251' port='24007'/>
      </source>
      <target dev='vda' bus='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    </disk>

# virsh start r6-qcow2
Domain r6-qcow2 started

2. do snapshot with --disk-only
# virsh snapshot-create-as r6-qcow2 s1 --disk-only
error: unsupported configuration: source for disk 'vda' is not a regular file; refusing to generate external snapshot name

3. do snapshot without --disk-only
# virsh snapshot-create-as r6-qcow2 snap1
Domain snapshot snap1 created

# virsh snapshot-list r6-qcow2
 Name                 Creation Time             State
------------------------------------------------------------
 snap1                2013-10-23 00:09:59 +0800 running

4. check the snapshot xml
# virsh snapshot-create-as r6-qcow2 s1 --disk-only --print-xml
<domainsnapshot>
  <name>s1</name>
</domainsnapshot>

# virsh snapshot-create-as r6-qcow2 snap1 --print-xml
<domainsnapshot>
  <name>snap1</name>
</domainsnapshot>

# virsh snapshot-dumpxml r6-qcow2 snap1
<domainsnapshot>
  <name>snap1</name>
  <state>running</state>
  <creationTime>1382458199</creationTime>
  <memory snapshot='internal'/>
  <disks>
    <disk name='vda' snapshot='internal'/>
  </disks>
  <domain type='kvm'>
    <name>r6-qcow2</name>
 .......
      <disk type='network' device='disk'>
        <driver name='qemu' type='qcow2'/>
        <source protocol='gluster' name='gluster-vol1/redhat6-qcow2.img'>
          <host name='10.66.82.251' port='24007'/>
        </source>
        <target dev='vda' bus='virtio'/>
        <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
      </disk>
......
    </devices>
    <seclabel type='dynamic' model='selinux' relabel='yes'/>
  </domain>
</domainsnapshot>

Actual results:
In step2, got error: unsupported configuration

Expected results:
In step2, snapshot-create-as --disk-only success.
Comment 2 Eric Blake 2013-10-23 00:30:02 EDT
Libvirt can't create a snapshot with a destination of gluster until it can support gluster backing chains.

*** This bug has been marked as a duplicate of bug 1017289 ***

Note You need to log in before you can comment on or make changes to this bug.