Bug 1022333 - Unable to remove product from a recipeset, ajax query gives 500.
Unable to remove product from a recipeset, ajax query gives 500.
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.15
Unspecified Unspecified
medium Severity medium (vote)
: 0.15.3
: ---
Assigned To: Dan Callaghan
tools-bugs
:
: 1043429 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 01:36 EDT by xjia
Modified: 2018-02-05 19:41 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-02 23:51:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Raymond Mancy 2013-10-23 21:09:40 EDT
product_id is being set to 0 instead of NULL.
Comment 3 Raymond Mancy 2013-10-23 21:29:52 EDT
This is also the case when directly removing the product from the recipeset.
Comment 4 Dan Callaghan 2013-12-17 18:08:35 EST
*** Bug 1043429 has been marked as a duplicate of this bug. ***
Comment 5 Dan Callaghan 2013-12-17 18:52:25 EST
Judging by the git history this is not a regression, I believe this case has never worked since the feature was added in Beaker 0.5.63.
Comment 6 Dan Callaghan 2013-12-17 19:44:52 EST
http://gerrit.beaker-project.org/2623
Comment 9 Nick Coghlan 2014-02-02 23:51:43 EST
This change is included in the Beaker 0.15.3 maintenance release:

http://beaker-project.org/docs/whats-new/release-0.15.html#beaker-0-15-3

Note You need to log in before you can comment on or make changes to this bug.