Bug 102239 - Evolution 1.4 breaks handling of vfolder filters
Summary: Evolution 1.4 breaks handling of vfolder filters
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-12 21:11 UTC by Alan Cox
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-21 16:21:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Cox 2003-08-12 21:11:02 UTC
Description of problem:
Evolution fails to regenerate folder filters properly in some cases

How reproducible:
100%

Steps to Reproduce:
1. Create a vfolder of your main received that is mail that is unread
2. View this folder
3. Read some messages
4. Hit ctrl-Y to redo the filters
    
Actual results:

Nothing happens

Expected results:

Read messages vanish as per 1.2

Select-all, ctrl-y turns them to ruled through, but wont remove them from the
view even if you refresh that.

Comment 1 Jeremy Katz 2003-09-02 22:59:40 UTC
I'm pretty sure they'll only vanish if you select "Hide read messages" which
isn't  a toggle-able option, but something you select each time you want to do
it (otherwise, it's weird in that you start to read a message and it vanishes
before you finish reading it).  

Or are you seeing something else and I'm not understanding?


Comment 2 Alan Cox 2003-09-02 23:25:10 UTC
In evolution 1.2 you can "select all messages" "apply filters" in a vfolder and
it updates it. In 1.4 this fails. Thats the problem I'm seeing - and its a
definite reversion in behaviour from correct to nonfunctional.

In my case the vfolder rule for membership is "Not Read || Important", the
filter isn't being reapplied properly when I tell it to


Comment 3 Matt Hansen 2004-04-27 03:58:02 UTC
What's the status on this? I have setup a Vfolder like Alan described
for the fedora mailing lists. Since they can and usually are quite
high volume, I would love to be able to automatically/permanently hide
all read messages in this folder _when I leave_ the Vfolder. 

What is the feasibility of this? This may not be possible, but having
the Ctrl+Y combo "refresh" the message state as Alan described would
be an acceptable alternative. 

Comment 4 Alan Cox 2004-05-21 20:24:18 UTC
I suspect its a case of "when Evolution 2.0 appears".



Note You need to log in before you can comment on or make changes to this bug.