Bug 1022413 - JGroups: Intermittent failures in org.jgroups.blocks.RpcDispatcherTest
JGroups: Intermittent failures in org.jgroups.blocks.RpcDispatcherTest
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Clustering (Show other bugs)
6.2.0,6.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: EAP 6.4.0
Assigned To: Richard Achmatowicz
Jitka Kozana
Russell Dickenson
JGroups testsuite
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 04:51 EDT by Richard Janík
Modified: 2014-10-25 08:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-29 10:36:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JGRP-1799 Major Resolved RpcDispatcher test fails when working with large values 2014-08-29 10:34:10 EDT

  None (edit)
Description Richard Janík 2013-10-23 04:51:47 EDT
Description of problem:

EAP 6.2.0.ER6
JGroups 3.2.12.Final

There is an occasional failure in org.jgroups.blocks.RpcDispatcherTest.testLargeReturnValue:

Error Message

null

Stacktrace


java.lang.AssertionError 
at org.jgroups.blocks.RpcDispatcherTest._testLargeValue(RpcDispatcherTest.java:558) 
at org.jgroups.blocks.RpcDispatcherTest.testLargeReturnValue(RpcDispatcherTest.java:436) 
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) 
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) 
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) 
at java.lang.reflect.Method.invoke(Method.java:606) 
at org.testng.internal.MethodInvocationHelper.invokeMethod(MethodInvocationHelper.java:80) 
at org.testng.internal.InvokeMethodRunnable.runOne(InvokeMethodRunnable.java:46) 
at org.testng.internal.InvokeMethodRunnable.run(InvokeMethodRunnable.java:37) 
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) 
at java.util.concurrent.FutureTask.run(FutureTask.java:262) 
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) 
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) 
at java.lang.Thread.run(Thread.java:724) 


https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-JGroups/job/eap-6x-manu-jgroups-rhel/23/jdk=java17_default,label=RHEL5_x86/testReport/org.jgroups.blocks/RpcDispatcherTest/testLargeReturnValue_2/
Comment 1 Richard Achmatowicz 2014-03-27 10:58:43 EDT
I still see this occasionally on Windows. From the investigation in the upstream issue, it was clear that some of the failures were just due to the processing taking longer on some slow machines. And Windows machines ARE slow. 

To rule out these last cases of failure, we could try with a timeout longer than 60 seconds (the current).
Comment 2 Richard Janík 2014-06-02 03:33:48 EDT
Still seeing this with 6.3.0.ER5 on RHEL (although it is RHEL7 and I think these machines are slow as well). I've made the timeout longer, we'll see what it does in the future.
Comment 4 Paul Ferraro 2014-08-29 10:36:23 EDT
This was fixed in JGroups 3.2.13.Final.

Note You need to log in before you can comment on or make changes to this bug.