Bug 1022420 - usbmuxd yum update fails when deleting old version 1.0.8-8
usbmuxd yum update fails when deleting old version 1.0.8-8
Status: CLOSED DUPLICATE of bug 1017493
Product: Fedora
Classification: Fedora
Component: usbmuxd (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 05:05 EDT by FENG Haibo
Modified: 2013-10-23 05:35 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-23 05:35:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description FENG Haibo 2013-10-23 05:05:26 EDT
[haibo@fhbfcl lnx_wks]$ sudo yum update usbmuxd
[sudo] password for haibo: 
Loaded plugins: fastestmirror, langpacks, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: free.nchc.org.tw
 * rpmfusion-free-rawhide: mirrors.ustc.edu.cn
 * rpmfusion-nonfree-rawhide: mirror.bjtu.edu.cn
 * updates: mirrors.163.com
 * updates-testing: mirror.bjtu.edu.cn
Resolving Dependencies
--> Running transaction check
---> Package usbmuxd.i686 0:1.0.8-8.fc20 will be updated
---> Package usbmuxd.i686 0:1.0.8-10.fc20 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

=================================================================================================================================================================
 Package                               Arch                               Version                                     Repository                            Size
=================================================================================================================================================================
Updating:
 usbmuxd                               i686                               1.0.8-10.fc20                               fedora                                69 k

Transaction Summary
=================================================================================================================================================================
Upgrade  1 Package

Total download size: 69 k
Is this ok [y/d/N]: y
Downloading packages:
Delta RPMs reduced 69 k of updates to 37 k (46% saved)
usbmuxd-1.0.8-8.fc20_1.0.8-10.fc20.i686.drpm                                                                                              |  37 kB  00:00:03     
Finishing delta rebuilds of 1 package(s) (69 k)
/var/cache/yum/i386/20/fedora/packages/usbmuxd-1.0.8-8.fc20_1.0.8-10.fc20.i686.drpm: md5 mismatch of result
Some delta RPMs failed to download or rebuild. Retrying..
usbmuxd-1.0.8-10.fc20.i686.rpm                                                                                                            |  69 kB  00:00:02     
-----------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                             17 kB/s | 106 kB     00:06     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating   : usbmuxd-1.0.8-10.fc20.i686                                                                                                                    1/2 
/var/tmp/rpm-tmp.Scb97X: line 1: fg: no job control
/var/tmp/rpm-tmp.Scb97X: line 3: fg: no job control
/var/tmp/rpm-tmp.Scb97X: line 5: fg: no job control
error: %preun(usbmuxd-1.0.8-8.fc20.i686) scriptlet failed, exit status 1
Error in PREUN scriptlet in rpm package usbmuxd-1.0.8-8.fc20.i686
  Verifying  : usbmuxd-1.0.8-10.fc20.i686                                                                                                                    1/2 
  Verifying  : usbmuxd-1.0.8-8.fc20.i686                                                                                                                     2/2 

Updated:
  usbmuxd.i686 0:1.0.8-10.fc20                                                                                                                                   

Failed:
  usbmuxd.i686 0:1.0.8-8.fc20                                                                                                                                    

Complete!
Comment 1 FENG Haibo 2013-10-23 05:07:27 EDT
So after upgrade there are 2 versions of usbmuxd:
[haibo@fhbfcl lnx_wks]$ rpm -qa|grep usbmuxd
usbmuxd-1.0.8-10.fc20.i686
usbmuxd-1.0.8-8.fc20.i686
Comment 2 FENG Haibo 2013-10-23 05:11:22 EDT
rpm remove fails either:
[haibo@fhbfcl ~]$ sudo rpm -e usbmuxd  --nodeps
[sudo] password for haibo: 
/var/tmp/rpm-tmp.XAfIEo: line 1: fg: no job control
/var/tmp/rpm-tmp.XAfIEo: line 3: fg: no job control
/var/tmp/rpm-tmp.XAfIEo: line 5: fg: no job control
error: %preun(usbmuxd-1.0.8-8.fc20.i686) scriptlet failed, exit status 1
error: usbmuxd-1.0.8-8.fc20.i686: erase failed
Comment 3 FENG Haibo 2013-10-23 05:12:30 EDT
I originally install fedora Alpha 4, and update all. This issue happens.
Comment 4 Panu Matilainen 2013-10-23 05:35:43 EDT
The scripts in the old version are broken, which is what the updated version fixes. The broken scripts from the buggy package get executed upon its removal, preventing it from getting cleanly erased. 'rpm -e --noscripts usbmuxd-1.0.8-8.fc20.i686' to get rid of the buggy version.

*** This bug has been marked as a duplicate of bug 1017493 ***

Note You need to log in before you can comment on or make changes to this bug.