Bug 1022421 - Error appeared during Puppet run: IPADDRESS_keystone.pp
Error appeared during Puppet run: IPADDRESS_keystone.pp
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: GA
: Havana
Assigned To: Martin Magr
yeylon@redhat.com
:
Depends On:
Blocks: 1022686
  Show dependency treegraph
 
Reported: 2013-10-23 05:06 EDT by Boris Derzhavets
Modified: 2016-04-18 03:13 EDT (History)
13 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.11.dev847.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 19:10:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 55424 None None None Never

  None (edit)
Description Boris Derzhavets 2013-10-23 05:06:43 EDT
Description of problem:

SequenceError: Error appeared during Puppet run: 192.168.1.136_keystone.pp
Error: /Stage[main]/Keystone::Roles::Admin/Keystone_role[_member_]: Could not evaluate: Expected 2 columns for role row, found 0. Line +----------------------------------+----------+^[[0m


Version-Release number of selected component (if applicable):
openstack-packstack-2013.2.1-0.12.dev806.fc20.noarch
openstack-keystone-2013.2-1.fc20.noarch

How reproducible:

Reproduce instructions

Steps to Reproduce:

All steps at http://openstack.redhat.com/Quickstart

Actual results:

keystone_pp failure

Expected results:

keystone_pp [DONE]

Additional info:
Comment 1 Boris Derzhavets 2013-10-23 05:18:00 EDT
2013-10-23 11:51:34::ERROR::run_setup::910::root:: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 891, in main
    single_step_aio_install(options)
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 663, in single_step_aio_install
    single_step_install(options)
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 693, in single_step_install
    _main(answerfilepath)
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 573, in _main
    runSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 552, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/setup_controller.py", line 90, in runAllSequences
    sequence.run(self.CONF)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 105, in run
    step.run(config=config)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 52, in run
    raise SequenceError(str(ex))
SequenceError: Error appeared during Puppet run: 192.168.1.136_keystone.pp
Error: /Stage[main]/Keystone::Roles::Admin/Keystone_role[_member_]: Could not evaluate: Expected 2 columns for role row, found 0. Line +----------------------------------+----------+^[[0m
Comment 2 Pádraig Brady 2013-10-23 08:16:40 EDT
There is a workaround for this in RDO.

  yum install python-backports

That will install version 1.0-4 of that package,
in the unlikely case that an older version of the package is already
on your system before initiating the openstack install.

Please install this package and rerun packstack (with the --answer-file option since it's a rerun):

If you do have python-backports-1.0-4 installed
and you're still hitting the issue, then I'm surprised
as that workaround was tested to work.
Comment 3 Martin Magr 2013-10-23 09:24:47 EDT
So if this is a puppet module bug, can you please comment here what's wrong?
Comment 4 Boris Derzhavets 2013-10-23 11:18:27 EDT
(In reply to Pádraig Brady from comment #2)
> There is a workaround for this in RDO.
> 
>   yum install python-backports
> 
> That will install version 1.0-4 of that package,
> in the unlikely case that an older version of the package is already
> on your system before initiating the openstack install.
> 
> Please install this package and rerun packstack (with the --answer-file
> option since it's a rerun):
> 
> If you do have python-backports-1.0-4 installed
> and you're still hitting the issue, then I'm surprised
> as that workaround was tested to work.

Thank you very much for quick response. It works.
Actually to run packstack smoothly :-

$ sudo yum -y update
$ sudo yum install -y http://rdo.fedorapeople.org/openstack-havana/rdo-release-havana.rpm
$ sudo yum install -y openstack-packstack
$ sudo yum update
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package python-backports.x86_64 0:1.0-3.fc19 will be updated
---> Package python-backports.x86_64 0:1.0-4.fc20 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================
 Package                          Arch                   Version                       Repository                        Size
======================================================================
Updating:
 python-backports                 x86_64                 1.0-4.fc20                    openstack-havana                 4.8 k

Transaction Summary
=======================================================================
Upgrade  1 Package

Total download size: 4.8 k
Is this ok [y/d/N]: y
Downloading packages:
No Presto metadata available for openstack-havana
python-backports-1.0-4.fc20.x86_64.rpm                                                                 | 4.8 kB  00:00:00     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating   : python-backports-1.0-4.fc20.x86_64                                                                         1/2 
  Cleanup    : python-backports-1.0-3.fc19.x86_64                                                                         2/2 
  Verifying  : python-backports-1.0-4.fc20.x86_64                                                                         1/2 
  Verifying  : python-backports-1.0-3.fc19.x86_64                                                                         2/2 

Updated:
  python-backports.x86_64 0:1.0-4.fc20                                                                                        
Complete!

$ packstack --allinone
Comment 5 Pádraig Brady 2013-10-23 13:05:27 EDT
@Boris glad the workaround worked.

@Martin, There are 2 issues that need to be addressed.

1. python-backports contains 2 versions of its module.
One in /usr/lib and one in /usr/lib64
which causes a warning about already added paths,
when python-babel uses pkg_resources.
Ian why are both locations included in the rpm?

2. The keystone puppet modules are actually parsing
stderr and thus this warning is tripping them up.
The puppet modules need to stop doing that as
it's far too brittle.
Comment 6 Alan Pevec 2013-10-24 07:38:18 EDT
> 2. The keystone puppet modules are actually parsing
> stderr and thus this warning is tripping them up.
> The puppet modules need to stop doing that as
> it's far too brittle.

Not just keystone puppet module, IIRC Xavier saw similar failures in glance puppet module, so all openstack modules parsing openstack client CLI output are suspect.
Comment 7 Alan Pevec 2013-10-24 07:46:35 EDT
> 1. python-backports contains 2 versions of its module.
> One in /usr/lib and one in /usr/lib64
> which causes a warning about already added paths,
> when python-babel uses pkg_resources.
> Ian why are both locations included in the rpm?

Setting needinfo from Ian for above.
Comment 8 b24warbaby 2014-08-19 09:42:27 EDT
I am seeing this with the apply python rpm:

[root@ab763 ~]# rpm -qa | grep openstack
openstack-keystone-2014.1.1-1.el6.noarch
openstack-packstack-puppet-2014.1.1-0.25.dev1208.el6.noarch
openstack-packstack-2014.1.1-0.25.dev1208.el6.noarch
openstack-puppet-modules-2014.1-19.3.el6.noarch
openstack-selinux-0.1.3-2.el6ost.noarch

yum install python-backports
Package python-backports-1.0-4.el6.x86_64 already installed and latest version
Nothing to do
Comment 9 b24warbaby 2014-08-19 09:42:43 EDT
I am seeing this with the apply python rpm:

[root@ab763 ~]# rpm -qa | grep openstack
openstack-keystone-2014.1.1-1.el6.noarch
openstack-packstack-puppet-2014.1.1-0.25.dev1208.el6.noarch
openstack-packstack-2014.1.1-0.25.dev1208.el6.noarch
openstack-puppet-modules-2014.1-19.3.el6.noarch
openstack-selinux-0.1.3-2.el6ost.noarch

yum install python-backports
Package python-backports-1.0-4.el6.x86_64 already installed and latest version
Nothing to do
Comment 11 Adam Gordon 2015-12-03 18:04:57 EST
> There is a workaround for this in RDO.
>
>  yum install python-backports
I just tried this on a fresh install of Fedora Server 23
i'm getting this error in /var/tmp/packstack/20151203-165733-59yZ4i/manifests/192.168.1.218_keystone.pp.log
Error: Failed to apply catalog: Execution of '/usr/bin/openstack project list --quiet --format csv --long' returned 1: Internal Server Error (HTTP 500)

Note You need to log in before you can comment on or make changes to this bug.