Bug 1022423 - /usr/share/wayland-sessions is not owned by this package
/usr/share/wayland-sessions is not owned by this package
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: filesystem (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 05:19 EDT by Parag Nemade
Modified: 2014-12-06 05:26 EST (History)
3 users (show)

See Also:
Fixed In Version: filesystem-3.2-28.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-14 08:31:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2013-10-23 05:19:36 EDT
Description of problem:
# rpm -qf /usr/share/wayland-sessions
file /usr/share/wayland-sessions is not owned by any package


Version-Release number of selected component (if applicable):
gnome-session-3.10.1-1.fc20.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
file /usr/share/wayland-sessions is not owned by any package

Expected results:
file /usr/share/wayland-sessions should be owned by this package

Additional info:
Comment 1 Parag Nemade 2014-02-24 10:53:54 EST
No reply yet. ping.
Comment 2 Ray Strode [halfline] 2014-02-27 10:00:57 EST
it's the wayland analogue of /usr/share/xsessions so should probably be added to filesystem.
Comment 3 Ondrej Vasik 2014-02-27 11:42:17 EST
Sounds fine to me as I read the https://blogs.gnome.org/ovitters/2013/10/10/wayland-vs-usrsharexsessions/ for the reasons why /usr/share/xsessions is not used by wayland.
However, as this can create a precedens, maybe some xorg-filesystem package would make sense in future - to own and create the xorg specific directories. Having this part of filesystem means this directory will get created for all users (not a big deal atm, though).
Comment 4 Parag Nemade 2014-07-10 03:56:20 EDT
any updates here?
Comment 5 Ondrej Vasik 2014-07-11 15:48:18 EDT
Sorry, got of my radar - setting needinfo to me to get this included into the next rawhide filesystem package.
Comment 6 Ondrej Vasik 2014-07-14 08:31:43 EDT
Built in rawhide as filesystem-3.2-27.fc22 . Will update f21/f20 in the case of something else will appear for filesystem as not owned directory is relatively harmless.
Comment 7 Fedora Update System 2014-11-18 07:55:53 EST
filesystem-3.2-28.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/filesystem-3.2-28.fc21
Comment 8 Fedora Update System 2014-12-06 05:26:44 EST
filesystem-3.2-28.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.