Bug 1022439 - Cannot perform app restart with missing httpd.pid file
Cannot perform app restart with missing httpd.pid file
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Michal Fojtik
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 05:46 EDT by Chris Ryan
Modified: 2015-05-14 19:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:26:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ryan 2013-10-23 05:46:08 EDT
Description of problem:
This is related to bug 975700. If the httpd.pid file is missing, the app will not restart.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a php-5.3 application: 
   rhc app-create phptest php-5.3
2. SSH to the app and delete the httpd.pid file:
   rhc ssh phptest
   cd php/run
   rm httpd.pid
3. Restart the app:
   rhc app restart -a phptest

Actual results:
The restart fails with:
Unable to complete the requested operation due to: Failed to correctly execute all parallel operations.
Reference ID: 6773811579144a6f0633299c88259a13

Expected results:
The app should restart.

Additional info:
Note: this works if the app is simply "started," with rhc app start -a phptest. The httpd.pid file is regenerated. It will not regenerate with a 'restart', however.
Comment 2 Michal Fojtik 2013-10-24 07:28:00 EDT
PR: https://github.com/openshift/origin-server/pull/3979

Should be merged shortly. Thanks for reporting this!
Comment 3 openshift-github-bot 2013-10-24 08:52:11 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/b67be29bd2a40947ca50f7502e3605a695ae1988
Bug 1022439 - Restore missing httpd.pid when restarting PHP cart
Comment 4 Meng Bo 2013-10-24 22:56:22 EDT
Checked on devenv_3942,

After httpd.pid file been removed from php cartridge, the app can be restart successfully. And the pid file can be regenerated.

Note You need to log in before you can comment on or make changes to this bug.