Bug 1022485 - Failed to upload ontology - unexpected (and unknown) error was sent by the S-RAMP repository when PostgreSQL is used
Failed to upload ontology - unexpected (and unknown) error was sent by the S-...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER7
: 6.0.0
Assigned To: Thomas Hauser
Stefan Bunciak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 07:49 EDT by Pavol Srna
Modified: 2014-02-06 10:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (42.62 KB, application/zip)
2013-10-23 07:49 EDT, Pavol Srna
no flags Details
screenshot (134.45 KB, image/png)
2013-10-23 07:50 EDT, Pavol Srna
no flags Details

  None (edit)
Description Pavol Srna 2013-10-23 07:49:31 EDT
Created attachment 815350 [details]
logs

Description of problem:

Failed to upload ontology - unexpected (and unknown) error was sent by the S-RAMP repository. Happens with postgresql.

Please see screenshot and logs attached.
Comment 1 Pavol Srna 2013-10-23 07:50:32 EDT
Created attachment 815353 [details]
screenshot
Comment 3 Thomas Hauser 2013-10-23 09:33:06 EDT
Looking at the log, this is the root cause:
13:15:32,551 ERROR [org.infinispan.loaders.jdbc.TableManipulation] (http-localhost/127.0.0.1:8080-2) ISPN008011: Error while creating table; used DDL statement: 'CREATE TABLE "ispn_bucket_sramp"(id VARCHAR(500) NOT NULL, datum VARBINARY(60000), version BIGINT, PRIMARY KEY (id))': org.postgresql.util.PSQLException: ERROR: type "varbinary" does not exist

I believe that there are new scripts to help take care of this in post-beta builds. The new scripts contain correct data types for each individual database in the infinispan definition for S-RAMP. Relevant portion of the standalone.xml below:

            <cache-container name="modeshape">
                <local-cache name="sramp">
                    <locking isolation="NONE"/>
                    <transaction mode="NON_XA"/>
                    <string-keyed-jdbc-store datasource="java:jboss/datasources/srampDS" passivation="false" purge="false">
                        <string-keyed-table prefix="ispn_bucket">
                            <id-column name="id" type="VARCHAR(500)"/>
                            <data-column name="datum" type="VARBINARY(60000)"/>
                            <timestamp-column name="version" type="BIGINT"/>
                        </string-keyed-table>
                    </string-keyed-jdbc-store>
                </local-cache>
            </cache-container>

This infinispan definition requires different types on a per-vendor basis.
Comment 4 Thomas Hauser 2013-11-13 11:56:07 EST
The new infinispan definitions will be available in ER7.
Comment 5 Pavol Srna 2013-12-13 08:50:49 EST
Verified in ER7.

Note You need to log in before you can comment on or make changes to this bug.