Bug 1022548 - Read/Randread/Randrw performance regression
Read/Randread/Randrw performance regression
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Fam Zheng
Virtualization Bugs
: Regression, ZStream
Depends On:
Blocks: 1025138 1025596
  Show dependency treegraph
 
Reported: 2013-10-23 09:49 EDT by Xiaomei Gao
Modified: 2014-10-14 02:53 EDT (History)
14 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.417.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1025138 (view as bug list)
Environment:
Last Closed: 2014-10-14 02:53:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 Kevin Wolf 2013-10-25 03:08:23 EDT
Can you track the regression down to a specific build or smaller set of builds?
Comment 5 Quan Wenli 2013-10-25 04:33:14 EDT
(In reply to Kevin Wolf from comment #4)
> Can you track the regression down to a specific build or smaller set of
> builds?

Kevin, commment #0 has mentioned that this regression was introduced by following patch from qemu-kvm-0.12.1.2-2.391.el6.
 - kvm-block-Produce-zeros-when-protocols-reading-beyond-en.patch [bz#848070]
Comment 6 Xiaomei Gao 2013-10-25 08:34:41 EDT
Btw, kvm_exits frequency is much higher compared to old version on virtio_scsi driver in read/randread/randrw category. Besides, we can also see the issue on local format image with virtio_scsi driver in randrw category, but IOPS does not degrades on local raw format image. Through bisect analysis, we found the high kvm_exits frequency on virtio_scsi driver is also introduced by the patch in comment #5
Comment 8 Xiaomei Gao 2013-10-29 04:44:44 EDT
We could see a little performance degradation in randrw category on local format image. Besides, kvm_exits frequency is much higher on virtio_scsi driver in randrw category. Through bisect analysis, they are both introduced by the patch in comment #5, so i changed the title.
Comment 15 Ademar Reis 2013-11-08 19:47:22 EST
QE found issues with the fix while testing Bug 1025596 (z-stream clone of this one) and we need additional patches. Moving it back to assigned, Fam is taking care of it.
Comment 16 Qunfang Zhang 2013-11-12 22:20:24 EST
Hi, Fam

As we already have bug 1025596 to track the z-stream build, so if I understand correctly, this one is for 6.6 and we should have a rhel6.6 build (like -416) in the "Fixed In Version". :) correct me if I'm wrong. 

Thanks a lot for your tracking up on this issue so that QE could have a fixed build earlier to test!

Qunfang
Comment 17 Fam Zheng 2013-11-12 22:41:01 EST
(In reply to Qunfang Zhang from comment #16)
> Hi, Fam
> 
> As we already have bug 1025596 to track the z-stream build, so if I
> understand correctly, this one is for 6.6 and we should have a rhel6.6 build
> (like -416) in the "Fixed In Version". :) correct me if I'm wrong. 
> 
> Thanks a lot for your tracking up on this issue so that QE could have a
> fixed build earlier to test!
> 

Yes you are right. The status was a mistake.

Moving back to POST.

Fam
Comment 21 errata-xmlrpc 2014-10-14 02:53:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1490.html

Note You need to log in before you can comment on or make changes to this bug.