Bug 1022596 - nova: fail to open vnc console during create snapshot of instance
nova: fail to open vnc console during create snapshot of instance
Status: CLOSED DUPLICATE of bug 976240
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
4.0
x86_64 Linux
unspecified Severity medium
: ---
: 4.0
Assigned To: RHOS Maint
Ami Jeain
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 11:24 EDT by Dafna Ron
Modified: 2013-10-29 09:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-29 09:05:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (12.11 MB, application/x-xz)
2013-10-23 11:24 EDT, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1243742 None None None Never

  None (edit)
Description Dafna Ron 2013-10-23 11:24:49 EDT
Created attachment 815459 [details]
log

Description of problem:

we fail to open vnc console from horizon during create snapshot of instance 

Version-Release number of selected component (if applicable):

openstack-nova-compute-2013.2-0.25.rc1.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. configure gluster as cinder backend and start instances
2. boot several instances and create snapshots
3. try to open instance console

Actual results:

we fail to open console

Expected results:

we should succeed to open console 

Additional info:

2013-10-23 13:46:18.681 3943 DEBUG qpid.messaging.io.ops [-] SENT[4464950]: SessionCompleted(commands=[0-41597]) write_op /usr/lib/python2.6/site-packages/qpid/messaging/driver.py:686
2013-10-23 13:46:18.687 3943 ERROR nova.openstack.common.rpc.amqp [req-696761cc-53ad-4530-a053-84588eedca6e a660044c9b074450aaa45fba0d641fcc e27aae2598b94dca88cd0408406e0848] Exception during message handling
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp Traceback (most recent call last):
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/openstack/common/rpc/amqp.py", line 461, in _process_data
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     **args)
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/openstack/common/rpc/dispatcher.py", line 172, in dispatch
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     result = getattr(proxyobj, method)(ctxt, **kwargs)
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/compute/manager.py", line 353, in decorated_function
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     return function(self, context, *args, **kwargs)
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/exception.py", line 90, in wrapped
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     payload)
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/exception.py", line 73, in wrapped
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     return f(self, context, *args, **kw)
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/compute/manager.py", line 243, in decorated_function
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     pass
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/compute/manager.py", line 229, in decorated_function
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     return function(self, context, *args, **kwargs)
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/compute/manager.py", line 271, in decorated_function
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     e, sys.exc_info())
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/compute/manager.py", line 258, in decorated_function
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     return function(self, context, *args, **kwargs)
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/compute/manager.py", line 319, in decorated_function
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     % image_id, instance=instance)
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/compute/manager.py", line 309, in decorated_function
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     *args, **kwargs)
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/compute/manager.py", line 2293, in snapshot_instance
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     task_states.IMAGE_SNAPSHOT)
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/compute/manager.py", line 2324, in _snapshot_instance
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     update_task_state)
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/virt/libvirt/driver.py", line 1423, in snapshot
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     expected_state=task_states.IMAGE_PENDING_UPLOAD)
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/compute/manager.py", line 2321, in update_task_state
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     instance.save(expected_task_state=expected_state)
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/objects/base.py", line 139, in wrapper
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     ctxt, self, fn.__name__, args, kwargs)
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/conductor/rpcapi.py", line 497, in object_action
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     objmethod=objmethod, args=args, kwargs=kwargs)
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/rpcclient.py", line 85, in call
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     return self._invoke(self.proxy.call, ctxt, method, **kwargs)
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/rpcclient.py", line 63, in _invoke
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     return cast_or_call(ctxt, msg, **self.kwargs)
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/nova/openstack/common/rpc/proxy.py", line 130, in call
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp     exc.info, real_topic, msg.get('method'))
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp Timeout: Timeout while waiting on RPC response - topic: "conductor", RPC method: "object_action" info: "<unknown>"
2013-10-23 13:46:18.687 3943 TRACE nova.openstack.common.rpc.amqp 
2013-10-23 13:46:18.691 3943 DEBUG qpid.messaging.io.raw [-] SENT[4464950]: '\x0f\x01\x00\x19\x00\x01\x00\x00\x00\x00\x00\x00\x04\n\x01\x00\x07\x00\x010\x00\x00\x00\x00\x01\x0f\x00\x00\x1a\x00\x00\x00\x00\x00\x00\x00\x00\x02\n\x01\x00\x0
0\x08\x00\x00\x00\x00\x00\x00\xa2}' writeable /usr/lib/python2.6/site-packages/qpid/messaging/driver.py:480
Comment 1 Xavier Queralt 2013-10-29 09:05:23 EDT
Dafna, could you try it again with the latest puddle? I've enabled live snapshots in the latest build of nova and now vnc shouldn't disconnect.

*** This bug has been marked as a duplicate of bug 976240 ***

Note You need to log in before you can comment on or make changes to this bug.