Bug 1022644 - Review Request: php-gliph - A graph library for PHP
Summary: Review Request: php-gliph - A graph library for PHP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Remi Collet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-10-23 17:12 UTC by Shawn Iwinski
Modified: 2013-11-23 02:38 UTC (History)
3 users (show)

Fixed In Version: php-gliph-0.1.5-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-12 00:37:59 UTC
fedora: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)
phpci.log (13.15 KB, text/plain)
2013-10-24 15:33 UTC, Remi Collet
no flags Details
review.txt (6.79 KB, text/plain)
2013-10-24 15:41 UTC, Remi Collet
no flags Details

Description Shawn Iwinski 2013-10-23 17:12:49 UTC
Spec URL: https://raw.github.com/siwinski/rpms/344f7399cf6f60e15e2e9faaef3e2d2a4bdc8e9d/php-gliph.spec

SRPM URL: http://siwinski.fedorapeople.org/SRPMS/php-gliph-0.1.4-1.fc19.src.rpm

Description:
Gliph is a graph library for PHP. It provides graph building blocks and
data structures for use by other PHP applications. It is (currently) designed
for use with in-memory graphs, not for interaction with a graph database like
Neo4J (http://neo4j.org/).


Fedora Account System Username: siwinski

Comment 1 Remi Collet 2013-10-24 15:31:39 UTC
I plan to review this "small" one before another "hude" one ;)

Please add a link to https://github.com/sdboyer/gliph/issues/1

"Common licenses that require including their texts with all derivative works include ASL 2.0, EPL, BSD and MIT."

So this will be a blocker.

Comment 2 Remi Collet 2013-10-24 15:33:42 UTC
Created attachment 815836 [details]
phpci.log

phpcompatinfo version 2.24.0.

Comment 3 Remi Collet 2013-10-24 15:41:13 UTC
Created attachment 815838 [details]
review.txt

Generated by fedora-review 0.5.0 (920221d) last change: 2013-08-30
Command line :/usr/bin/fedora-review -b 1022644
Buildroot used: fedora-19-x86_64
Active plugins: Generic, PHP, Shell-api
Disabled plugins: Java, C/C++, Python, SugarActivity, Perl, R, Ruby
Disabled flags: EPEL5, EXARCH, DISTTAG

Comment 4 Remi Collet 2013-10-24 15:43:25 UTC
[!]: Requires correct, justified where necessary.
	php-common => php(language)

[!]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.

	"Common licenses that require including their texts with all
	derivative works include ASL 2.0, EPL, BSD and MIT."
	=> have to wait for upstream to add this file
		https://github.com/sdboyer/gliph/issues/1
	=> So this will be a blocker.


As LICENSE is now part of upstream repo, you can add it 
Source1:  https://raw.github.com/sdboyer/gliph/php53/LICENSE

Comment 5 Remi Collet 2013-10-24 15:45:38 UTC
Small notice, I don't think it make sense to have a %{github_version}.

Comment 6 Shawn Iwinski 2013-10-24 19:13:36 UTC
(In reply to Remi Collet from comment #5)
> Small notice, I don't think it make sense to have a %{github_version}.

For GitHub packages, I like to see all the GitHub information at the top vs. some at the top and some lower down in the spec.  Since the version is actually the GitHub tag I like to include that at the top.


(In reply to Remi Collet from comment #4)
> [!]: Requires correct, justified where necessary.
> 	php-common => php(language)

I hang my head in shame :(


> [!]: If the source package does not include license text(s) as a separate
> file
>      from upstream, the packager SHOULD query upstream to include it.
> 
> 	"Common licenses that require including their texts with all
> 	derivative works include ASL 2.0, EPL, BSD and MIT."
> 	=> have to wait for upstream to add this file
> 		https://github.com/sdboyer/gliph/issues/1
> 	=> So this will be a blocker.
> 
> 
> As LICENSE is now part of upstream repo, you can add it 
> Source1:  https://raw.github.com/sdboyer/gliph/php53/LICENSE

I hang my head in shame again :(  I noticed this but didn't account for it in the spec :(  I updated to the latest snapshot since it now contains the LICENSE file.



Update diff: https://github.com/siwinski/rpms/commit/2a69ec1373c680577274fdc5fb24faa28ab87fd4



Spec URL: https://github.com/siwinski/rpms/blob/2a69ec1373c680577274fdc5fb24faa28ab87fd4/php-gliph.spec

SRPM URL: http://siwinski.fedorapeople.org/SRPMS/php-gliph-0.1.4-1.20131024git8da23c6.fc19.src.rpm

Comment 7 Remi Collet 2013-10-25 05:26:09 UTC
[x]: Requires correct, justified where necessary.
[-]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.


Blocker fixed.

=== APPROVED ===

Comment 8 Shawn Iwinski 2013-11-05 18:28:36 UTC
THANKS for the review!


New Package SCM Request
=======================
Package Name: php-gliph
Short Description: A graph library for PHP
Owners: siwinski
Branches: f19 f20 el6
InitialCC:

Comment 9 Gwyn Ciesla 2013-11-05 18:48:01 UTC
Git done (by process-git-requests).

Comment 10 Fedora Update System 2013-11-06 16:58:47 UTC
php-gliph-0.1.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/php-gliph-0.1.5-1.fc20

Comment 11 Fedora Update System 2013-11-06 16:59:00 UTC
php-gliph-0.1.5-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/php-gliph-0.1.5-1.el6

Comment 12 Fedora Update System 2013-11-06 16:59:10 UTC
php-gliph-0.1.5-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/php-gliph-0.1.5-1.fc19

Comment 13 Fedora Update System 2013-11-07 03:38:32 UTC
php-gliph-0.1.5-1.fc19 has been pushed to the Fedora 19 testing repository.

Comment 14 Fedora Update System 2013-11-12 00:37:59 UTC
php-gliph-0.1.5-1.fc20 has been pushed to the Fedora 20 stable repository.

Comment 15 Fedora Update System 2013-11-15 20:34:24 UTC
php-gliph-0.1.5-1.fc19 has been pushed to the Fedora 19 stable repository.

Comment 16 Fedora Update System 2013-11-23 02:38:08 UTC
php-gliph-0.1.5-1.el6 has been pushed to the Fedora EPEL 6 stable repository.


Note You need to log in before you can comment on or make changes to this bug.