Bug 10227 - "ndc restart" doesn't honour bind's gid/uid setting
Summary: "ndc restart" doesn't honour bind's gid/uid setting
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: bind   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-18 22:32 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-10 22:03:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-03-18 22:32:12 UTC
When Bind has been started with e.g. '-u bind -g bind', and if you do 'ndc
restart', bind will be restarted as root, not as bind:bind.

This seems to be the problem on other Unix variants too, so this is
probably a bug in ndc.

Comment 1 Nalin Dahyabhai 2000-04-10 22:03:59 UTC
This is an ndc bug, and it will be fixed in bind-8.2.2_P5-10, in Raw Hide
(ftp://ftp.redhat.com/pub/rawhide/).  I've sent a patch to ISC, so that they
can incorporate our fix if they don't have a better solution.

Comment 2 Pekka Savola 2000-04-14 17:52:59 UTC
Thanks a lot!

Could you also re-consider bug #8062?  The glibc21 patch breaks non-glibc21
builds.  Fixing this wouldn't be that difficult, even some attempt of mine to
fix the patch is included there :)


Note You need to log in before you can comment on or make changes to this bug.