Bug 1022710 - agent needs to be told what the server's endpoint is when rhqctl installs it
agent needs to be told what the server's endpoint is when rhqctl installs it
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Agent, Installer (Show other bugs)
JON 3.2
Unspecified Unspecified
high Severity high
: ER05
: JON 3.2.0
Assigned To: John Mazzitelli
Mike Foley
:
Depends On: 1022573
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2013-10-23 16:14 EDT by John Mazzitelli
Modified: 2014-01-02 15:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1022573
Environment:
Last Closed: 2014-01-02 15:35:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2013-10-23 16:14:45 EDT
+++ This bug was initially created as a clone of Bug #1022573 +++

The server no longer listens to 0.0.0.0 by default when you install it. You have to pick an IP address that the server will bind to (jboss.bind.address).

When you install the agent, we don't set explicitly the server address - we rely on the agent to use its default. This is one of two things - its either the IP from a DNS lookup of "rhqserver" alias, and if that is not found, it uses Java to look up the local hostname of the agent.

Usually, this is OK, unless you pick a server bind address that is different from what Java will pick up as the default hostname. If they are different, then the agent will fail to connect to the server.

Here is how I replicate this.

Build master - do not build a dev container, but just a production build (go in modules/enterprise/server/appserver and "mvn clean install").

From that build, run "rhqctl install --start" and when it prompts you, give it a jboss.bind.address of 127.0.0.1.

The agent will not be able to connect. That's because it will attempt to talk to the server on your hostname's non-loopback address (usually). On my box, it tries 192.168.x.x IP. But the server is not listening on that IP, its listening on 127.0.0.1 as I told it to.

The agent will therefore never be able to connect.

This is bad. Unless you are lucky and have a single network adapter with a single IP or Java happens to pick the IP that you pick, the agent won't be able to connect. The workaround is to set "rhqserver" alias in /etc/hosts so the agent can pick up the IP you want it to.

--- Additional comment from John Mazzitelli on 2013-10-23 16:13:54 EDT ---

git commit to master: 92f4f9c
Comment 1 John Mazzitelli 2013-10-24 16:14:28 EDT
git commit to release/jon3.2.x branch: 3d9d35d
Comment 2 Simeon Pinder 2013-11-06 21:17:35 EST
Moving to ON_QA for test with new brew build.
Comment 3 Filip Brychta 2013-11-08 05:27:17 EST
Verified on
Version :	
3.2.0.ER5
Build Number :	
2cb2bc9:225c796

Note You need to log in before you can comment on or make changes to this bug.