Bug 1022721 - Adding a new web proxy gear fails because it tries to rotate out/in the new proxy gear unnecessarily and prematurely
Adding a new web proxy gear fails because it tries to rotate out/in the new p...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andy Goldstein
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 16:49 EDT by Andy Goldstein
Modified: 2015-05-14 19:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:26:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Goldstein 2013-10-23 16:49:15 EDT
Description of problem: Adding a new web proxy gear will fail when the head gear tries to activate the code on the new gear - it will try to rotate out/in the new gear, but the new gear doesn't have a gear registry yet, so you get an exception. Also, there is no reason to rotate a new gear out/in when scaling up because it's not even in the haproxy configuration yet.


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Create scaled app
2. Try to make the app HA

Actual results: make-ha fails


Expected results: make-ha succeeds


Additional info:
Comment 1 Andy Goldstein 2013-10-23 17:09:07 EDT
https://github.com/openshift/origin-server/pull/3976
Comment 2 Meng Bo 2013-10-24 06:01:00 EDT
Checked on devenv_3939, the scalable app can be make-ha successfully.

And after that, all the gears have haproxy cartridge and gear registry.

Move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.