Bug 1022741 - USB 3 Controller dies after any device is connected (xHCI host not responding to stop endpoint command)
USB 3 Controller dies after any device is connected (xHCI host not responding...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 18:24 EDT by Marcin Czupryniak
Modified: 2014-01-07 01:45 EST (History)
7 users (show)

See Also:
Fixed In Version: 3.12.6 [Fedora 19]
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-07 01:41:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcin Czupryniak 2013-10-23 18:24:42 EDT
There is a problem with the xhci_hcd module, any device connected to the USB3 port kills the controller with following output from dmesg:

[  109.374047] ALSA sound/usb/endpoint.c:498 timeout: still 3 active urbs on EP #1
[  110.373720] ALSA sound/usb/endpoint.c:498 timeout: still 3 active urbs on EP #1
[  111.373414] ALSA sound/usb/endpoint.c:498 timeout: still 3 active urbs on EP #1
[  113.385736] xhci_hcd 0000:03:00.0: xHCI host not responding to stop endpoint command.
[  113.385754] xhci_hcd 0000:03:00.0: Assuming host is dying, halting host.
[  113.385790] xhci_hcd 0000:03:00.0: HC died; cleaning up
[  113.385823] usb 2-1: USB disconnect, device number 2
[  116.371744] xhci_hcd 0000:03:00.0: Timeout while waiting for configure endpoint command
[  116.371764] xhci_hcd 0000:03:00.0: Abort the command ring, but the xHCI is dead.
[  116.371768] usb 2-1: Not enough bandwidth for altsetting 0


The devices I tested were:

- USB headset (based on C-Media audio controller)
- USB Ethernet adapter (based on ASIX AX88772B)


The USB3 Host controller:

03:00.0 USB controller: Fresco Logic FL1009 USB 3.0 Host Controller (rev 02)

My system is an ASUS Ultrabook (Model UX31E 13") and this issue prevents me from using 1 of the 2 USB ports of the system (only the USB3 works properly).

Apparently everything works fine on Windows and the USB3 ports can be used without problems.
Comment 1 Marcin Czupryniak 2013-10-23 18:27:35 EDT
Sorry for typo, the only one port working is the USB2 not the USB3
Comment 2 Justin M. Forbes 2014-01-03 17:12:11 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.12.6-200.fc19.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 20, and are still experiencing this issue, please change the version to Fedora 20.

If you experience different issues, please open a new bug report for those.
Comment 3 Marcin Czupryniak 2014-01-07 01:41:58 EST
After the Kernel update to 3.12.6 this appears to be fixed.

Note You need to log in before you can comment on or make changes to this bug.