This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1022747 - Xdmx: second screen is unreachable
Xdmx: second screen is unreachable
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Peter Hutterer
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 19:09 EDT by Peter Hutterer
Modified: 2015-01-12 19:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-12 19:14:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Hutterer 2013-10-23 19:09:09 EDT
Description of problem:
The second screen is unreachable with the mouse pointer in Xdmx. 

Version-Release number of selected component (if applicable):
xorg-x11-server-Xdmx-1.13.0-23.el6

apparently also a problem in xorg-x11-server-Xorg-1.10.6-1.el6, so it's been there for a while.

Steps to Reproduce:
1. Xephyr -screen 640x480 -ac :1 &
2. Xephyr -screen 640x480 -ac :2 &
3. Xdmx -display :1 -display :2 -ac :4 &
4. try to move pointer into second screen
Comment 4 Peter Hutterer 2015-01-12 19:14:51 EST
This bug was filed by me based on a misunderstanding of how the input handling should work.

This behaviour is by design. Xdmx was written for display walls with dedicated input devices and (back in the day) the decision was made not support devices on each input display. On a normal deployment across multiple displays this makes sense.

The Xephyr use-case is primarily used for testing, it is acceptable that the input doesn't work across the screens. We can re-visit if a customer files a bug requesting this functionality.

Note You need to log in before you can comment on or make changes to this bug.