Bug 1022757 - probable dependency error
probable dependency error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
19
i686 Linux
unspecified Severity low
: ---
: ---
Assigned To: Thomas Spura
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 20:24 EDT by wayspataol
Modified: 2013-10-28 08:19 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 03:05:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wayspataol 2013-10-23 20:24:59 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 wayspataol 2013-10-23 20:30:56 EDT
Sorry, hit the enter key too fast before filling out the whole form

Here's the problem. When attempting to apply recently released patches via Software Update to:

python-2.7.5-8.fc19 (32-bit)
python-devel-2.7.5-8.fc19 (32-bit)
python-libs-2.7.5-8.fc19 (32-bit)
python-urlgrabber-3.10-0.fc19
tkinter-2.7.5-8.fc19 (32-bit)

the update fails with the error message:

ERROR with transaction check vs depsolve:
python(abi) = 2.5 is needed by rhpl-0.218-1.i386
python(abi) = 2.5 is needed by repoman-0.9-5.fc10.noarch
python(abi) = 2.6 is needed by python-psyco-1.6-4.fc12.i686
python(abi) = 2.6 is needed by alchemist-1.0.37-8.fc12.i686
python(abi) = 2.6 is needed by kudzu-1.2.86-2.i686
python(abi) = 2.6 is needed by system-config-display-2.2-1.fc12.i686
python-abi = 2.6 is needed by alchemist-1.0.37-8.fc12.i686


Since all the failed dependencies are on outdated packages, I suspect this is a package build issue.
Comment 2 Thomas Spura 2013-10-24 03:05:59 EDT
It seems those packages were orphaned and with updating to newer versions of Fedora, they are not cleaned up.

Could you verify this with:
# package-cleanup --orphans 

For further information see here:
http://docs.fedoraproject.org/en-US/Fedora/14/html/Software_Management_Guide/ch07s03.html
Comment 3 wayspataol 2013-10-24 18:31:56 EDT
Thomas-

Thank you for your prompt reply.

Yes, those 7 packages (along with almost 100 others, some dating back to fc9 -- I've had this install up for a *while*...) are reported by package-cleanup --orphans. Sorry if this a naive question but is the remedy to uninstall the orphans with yum remove?
Comment 4 Thomas Spura 2013-10-25 03:05:20 EDT
You could use:

yum remove $(package-cleanup --orphans | grep -v "Loaded plugins")

Other than that, I guess you need to clean them up manually.
Comment 5 wayspataol 2013-10-28 08:19:28 EDT
Orphaned package cleanup did solve my problem.

Thank you for your assistance.

Note You need to log in before you can comment on or make changes to this bug.