Bug 102277 - Permission denied when /dev is mounted read-only over NFS
Permission denied when /dev is mounted read-only over NFS
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-13 06:45 EDT by Julian Blake
Modified: 2015-01-04 17:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 20:56:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Blake 2003-08-13 06:45:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
If the device file directory is mounted read-only over NFS, 
write access is wrongly denied to device special files.  
For example:

cat ... >/dev/null
==> bash: /dev/null: Permission denied

mke2fs /dev/ram5
==> /dev/ram5: Permission denied while setting up superblock

Behaviour seen with kernel-2.4.21-20.1.2024.2.1.nptl (in Severn)
and with kernel 2.4.20-18.7.cern (in CERN Linux 7.3.3), but not
seen with kernel 2.4.18-27.7.cern (in CERN Linux 7.3.2).

Problem encountered when running netbooted Linux.  For background 
information, see
http://cern.ch/linux/redhat73/documentation/netboot

Version-Release number of selected component (if applicable):
kernel-2.4.21-20.1.2024.2.1.nptl

How reproducible:
Always

Steps to Reproduce:
1. Export /dev read-only, no_root_squash, from an NFS server.
2. Mount server:/dev read-only, nolock, on /mnt/nfs on an NFS client.
3. Try "cat somefile >/mnt/nfs/null"  and "mke2fs /mnt/nfs/ram5"
on the NFS client.

Actual Results:  Permission is denied, in both cases.

Expected Results:  Both commands (cat and mke2fs) should have worked normally.

Additional info:

If /dev is exported read/write, no_root_squash, from the server, 
and mounted with default options (read/write, lock) on the client, 
the two commands (cat and mke2fs) succeed.

Combinations tried:
- Server runs Severn, client runs CERN Linux 7.3.3.
- Server runs CERN Linux 7.3.3, client runs Severn.
- Server and client run CERN Linux 7.3.3.
- Server and client run CERN Linux 7.3.2.

Note You need to log in before you can comment on or make changes to this bug.