Bug 1022780 - English segment is divided into 3 chunks within the zanata file, causing strings that cannot be localized
English segment is divided into 3 chunks within the zanata file, causing stri...
Status: CLOSED NOTABUG
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Isaac Rooskov
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 23:17 EDT by Isaac Rooskov
Modified: 2015-08-06 01:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-24 02:00:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
original file screenshot (85.73 KB, image/png)
2013-10-23 23:17 EDT, Isaac Rooskov
no flags Details
Zanata file screenshot (101.72 KB, image/png)
2013-10-23 23:18 EDT, Isaac Rooskov
no flags Details

  None (edit)
Description Isaac Rooskov 2013-10-23 23:17:05 EDT
Created attachment 815601 [details]
original file screenshot

Description of problem:

We have found the part of strings cannot be localized after publican build.
Attached are the screen shots which show this unlocalized part where the corresponding segment in the original is divided into 3 chunks in the zanata file.

Version-Release number of selected component (if applicable):
3.0

How reproducible:
100%
Comment 1 Isaac Rooskov 2013-10-23 23:18:43 EDT
Created attachment 815602 [details]
Zanata file screenshot
Comment 2 Sean Flanigan 2013-10-24 02:00:22 EDT
Strings in DocBook files are not converted to PO by Zanata but by Publican (or Skynet).

It looks to me as if Publican/Skynet is treating the <orgname> element as a paragraph marker, instead of including it as an in-line element.  (My terminology is probably way off, since I don't have much to do with DocBook.)

If you report this as a bug to the Publican/Skynet team, I recommend pasting the relevant XML text and PO text into the bug report.  Playing "spot the bug" with two different screenshots isn't as fun as it sounds.

Note You need to log in before you can comment on or make changes to this bug.