Bug 10228 - Missing tapetype binary in amanda or amanda-server RPM
Missing tapetype binary in amanda or amanda-server RPM
Status: CLOSED NOTABUG
Product: Red Hat Powertools
Classification: Retired
Component: amanda (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-18 17:38 EST by Matthew Saltzman
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-26 16:56:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2000-03-18 17:38:21 EST
amanda-2.4.1p1-3 or amanda-server-2.4.1p1-3 RPMs do not include the
Amanda tapetype utility.  The source is included in the tape-src/
subdirectory, but the binary apparently has to be made as a separate
step ('make tapetype' in the tape-src/ directory), as it doesn't get
built with the rest of the package.
Comment 1 Tim Powers 2000-03-20 09:20:59 EST
Can you take a look at the version of amanda located in rawhide? You will have
to rebuild it with dump installed on your machine since it wasn't on my
buildroot (doh!). Check that out to make sure it works.

Tim
Comment 2 Matthew Saltzman 2000-03-20 10:39:59 EST
Nope, that doesn't have it either.  The docs suggest what I said before,
that the command must be built in a separate step.  I also noticed that
the step builds a "temporary wrapper script" in tape-src/, which includes
a warning that it won't work if moved out of the build directory.  I'm not
sure what's going on there.
Comment 3 Tim Powers 2000-03-20 12:19:59 EST
From waht I can tell, the tapetype script is generated so that you can run it
for *machine dependant information*, and it must be run from the source
directory otherwise it will not function properly. Here is a snippet from
examples/amanda.conf in the source:

	"# Define the type of tape you use here, and use it in "tapetype"
	 # above.  Some typical types of tapes are included here.  The tapetype
	 # tells amanda how many MB will fit on the tape, how big the filemarks
	 # are, and how fast the tape device is.

	 # A filemark is the amount of wasted space every time a tape section
	 # ends.  If you run `make tapetype' in tape-src, you'll get a program
	 # that generates tapetype entries, but it is slow as hell, use it only
	 # if you really must and, if you do, make sure you post the data to
	 # the amanda mailing list, so that others can use what you found out
	 # by searching the archives. "

This suggests that you can use it to generate some defines, but is not
completely necessary if it was generated by someone else. FWIW, a make is done
inside the tape-src directory, and the libraries are built and installed
(/usr/lib/libamtape*).

This is why we haven't built the package with this script, we would have to
install the source as part of the regular package in order for the tapetype
script to work. If you have an entry that hasn't been documented on this page:

http://www.cs.columbia.edu/~sdossick/amanda/

Then you may want to go ahead and build amanda by hand if you are concerned
about the tapetype definitions.

Tim
Comment 4 Matthew Saltzman 2000-03-26 16:56:59 EST
Yes, the point of the utility is to generate machine-dependent information,
but it's not for #defines in source code.  It's for a runtime config file:
/etc/amanda/*/amanda.conf.  It would be nice if one could test one's drive
for inclusion in this file without having to build the whole package from
source.

It looks like the main reason that the script is not relocatable is that
it is looking for some shared libs in particular locations.  I don't see
why the script couldn't be rewritten to invoke the executable correctly
when the package is installed, but that's basically a wish list item.

Note You need to log in before you can comment on or make changes to this bug.