Bug 1022801 - Can't display the Data Center subpool in the SAM web UI
Can't display the Data Center subpool in the SAM web UI
Status: CLOSED WONTFIX
Product: Subscription Asset Manager
Classification: Red Hat
Component: candlepin (Show other bugs)
1.3
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Adam Price
SAM QE List
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-10-24 01:50 EDT by Liushihui
Modified: 2014-06-25 11:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-25 11:17:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SAM-notification.log (18.66 KB, text/plain)
2013-10-24 01:50 EDT, Liushihui
no flags Details

  None (edit)
Description Liushihui 2013-10-24 01:50:51 EDT
Created attachment 815614 [details]
SAM-notification.log

Description of problem:
After host subscribe the Data center pool, The Data center subpool can display in the Guest's CLI but can't display in the SAM web UI 

Version-Release number of selected component (if applicable):
subscription-manager-1.9.9-1.el6.x86_64
python-rhsm-1.9.6-1.el6.x86_64
virt-who-0.8-9.el6.noarch
candlepin-0.8.26-1.el6sam.noarch
katello-headpin-1.4.3.20-1.el6sam_splice.noarch

How reproducible:
Always

Steps to Reproduce:
1. Register Host and Guest to SAM server, Host has subscribed Data center pool
# subscription-manager register --username=admin --password=admin
# subscription-manager subscribe --pool=8ac28c6341e82bae0141e82f59510249
Successfully attached a subscription for: Red Hat Enterprise Linux Server, Datacenter Standard
2. Open SAM web UI, Go to System-->All,Choose the Guest, check the Guest's available subscription, Data center subpool hasn't been displayed
3. In the Guest, run "subscription-manager list --available", it can display the Datacenter subpool.
[root@rhel65sp4 ~]# subscription-manager list --available
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name: Red Hat Enterprise Linux Server, Datacenter Standard
Provides:          Red Hat Beta
                   Red Hat Enterprise Linux 7 Public Beta
                   Red Hat Software Collections (for RHEL Server)
                   Red Hat Enterprise Linux Server
                   Red Hat Software Collections Beta (for RHEL Server)
SKU:               RH00050
Pool ID:           8ac28df541e83a900141e88de021003d
Available:         Unlimited
Suggested:         1
Service Level:     Standard
Service Type:      L1-L3
Multi-Entitlement: No
Ends:              12/31/2013
System Type:       Virtual
4. In the Guest, subscribe this subpool
# subscription-manager subscribe --pool="datacenter subpool id"
5. Open SAM web UI, Go to System-->All,Choose the guest, Click the "subscription" tab, it can't display all the subscriptions, it will pop up error message in the page as the following:
"undefined method `entitlementId' for nil:NilClass (NoMethodError)"

Actual results:
As the step2 and step5's result.

Expected results:
After step2, it should display the Data center subpool in the SAM web UI 
After step5, it should display all the subscriptions of the Guest, including the 
consumed pool and available pools.


Additional info:
see the detail error information of SAM web UI in the attachment.
Comment 1 Adam Price 2013-10-25 14:21:10 EDT
@Liushihui

I'm unable to reproduce this failure. What version of SAM did you install? 1.3.0? 1.3.1? Is this an upgraded installation?

Do you happen to have the manifest that you imported into your SAM server? That would help in tracking down this issue. Thank you.
Comment 2 Liushihui 2013-10-28 06:57:59 EDT
Hi, Adam
   The bug found on sam-1.3.1-RHEL-6-20131017.0, The SAM isn't upgraded installation but new fully installation. Maybe you can try it on our SAM environment:
   SAM IP: 10.66.13.117
Comment 5 Liushihui 2014-04-18 02:37:51 EDT
It can't reproduce on the latest RHEL-7.0-20140409.0(KVM) against SAM-1.4.0-RHEL-6-20140416.0, it only exist on SAM1.3

Version-Release number of selected component (if applicable):
subscription-manager-1.10.14-7.el7.x86_64
python-rhsm-1.10.12-2.el7.x86_64
virt-who-0.8-12.el7.noarch
katello-headpin-1.4.3.26-1.el6sam_splice.noarch
candlepin-0.9.6-1.el6_5.noarch
Comment 6 Bryan Kearney 2014-06-25 11:17:00 EDT
Since this is fixed in 1.4, I am closing this out.

Note You need to log in before you can comment on or make changes to this bug.