Bug 1022859 - Validate quota for empty UUID
Validate quota for empty UUID
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.4.0
Assigned To: Gilad Chaplik
Artyom
sla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 03:50 EDT by Gilad Chaplik
Modified: 2016-02-10 15:20 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-31 05:32:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilad Chaplik 2013-10-24 03:50:15 EDT
Description of problem:
no engine validation for quota, for empty UUID (000...).
Fails on FK, since there is no such a quota.

How reproducible:
100%


Steps to Reproduce:
1. create a VM/Disk and pass Empty string or empty UUID

Actual results:
creating fails

Expected results:
proper error message (quota is invalid)
Comment 1 Gilad Chaplik 2013-10-24 03:54:06 EDT
see bug 1021393 (foreman fails to create disk on empty string), and a temporary fix to it:
http://gerrit.ovirt.org/#/c/20466/2/backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddDiskCommand.java for additional
Comment 2 Doron Fediuck 2013-10-28 11:40:45 EDT
After consulting Ohad Levi, from Foreman's perspective a fix in oVirt 3.4.0 would better fit both sides. Therefore, suggesting 3.4.0 for this issue.
Comment 6 Doron Fediuck 2014-03-31 05:32:20 EDT
Since there's no related user request and a fix may introduce other risks,
closing this issue. 
If relevant please explain why and re-open.

Note You need to log in before you can comment on or make changes to this bug.