Bug 1022895 - Win8.1-32 guest installation stuck before entering the installer
Win8.1-32 guest installation stuck before entering the installer
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Yan Vugenfirer
Yiqian Wei
:
: 1209039 (view as bug list)
Depends On:
Blocks: 1401400
  Show dependency treegraph
 
Reported: 2013-10-24 05:02 EDT by CongLi
Modified: 2017-07-19 11:50 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-19 11:50:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot - Win8.1 installation stuck (14.48 KB, image/jpeg)
2013-10-24 05:02 EDT, CongLi
no flags Details
all debug file (258.47 KB, application/x-xz)
2013-10-24 05:08 EDT, CongLi
no flags Details
all debug file - win2012r2 guest (190.51 KB, application/x-xz)
2014-01-07 22:39 EST, CongLi
no flags Details
win2012r2 CML (virtio_blk and virtio_net) (3.03 KB, application/x-shellscript)
2014-02-11 01:45 EST, CongLi
no flags Details
screenshot (13.82 KB, image/jpeg)
2014-12-08 00:17 EST, ShupingCui
no flags Details
Boot loader error 0x0000000A for -M rhel6.4.0 (68.42 KB, image/png)
2015-04-05 07:55 EDT, Yan Vugenfirer
no flags Details
screenshot - Win8.1.i386 could not apply unattend answer file - QEMU 2.9 (45.28 KB, image/png)
2017-05-10 01:45 EDT, CongLi
no flags Details

  None (edit)
Description CongLi 2013-10-24 05:02:29 EDT
Created attachment 815686 [details]
screenshot - Win8.1 installation stuck

Description of problem:
Win8.1-32 guest installation stuck before entering the installer

Version-Release number of selected component (if applicable):
kernel-3.10.0-35.el7.x86_64
qemu-kvm-rhev-1.5.3-10.el7.x86_64

How reproducible:
Only Once

Steps to Reproduce:
1. Install a Win8.1-32 guest:
/home/staf-kvm-devel/autotest-devel/client/tests/virt/qemu/qemu \
    -S \
    -name 'virt-tests-vm1' \
    -nodefaults \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20131023-212155-v6TwC7HC,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control \
    -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20131023-212155-v6TwC7HC,server,nowait \
    -device isa-serial,chardev=serial_id_serial1 \
    -chardev socket,id=seabioslog_id_20131023-212155-v6TwC7HC,path=/tmp/seabios-20131023-212155-v6TwC7HC,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20131023-212155-v6TwC7HC,iobase=0x402 \
    -device nec-usb-xhci,id=usb1,bus=pci.0,addr=0x4 \
    -device ahci,id=ahci,addr=0x5 \
    -drive file='/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win8-32.qcow2',if=none,id=ahci0,media=disk,cache=none,snapshot=off,format=qcow2,aio=threads \
    -device ide-drive,bus=ahci.0,drive=ahci0 \
    -device e1000,netdev=iddXBmlr,mac='9a:ee:ef:f0:f1:f2',bus=pci.0,addr=0x3,id='idhYhwu0' \
    -netdev tap,id=iddXBmlr,fd=22 \
    -m 4096 \
    -smp 4,maxcpus=4,cores=2,threads=1,sockets=2 \
    -cpu 'SandyBridge',+sep \
    -M pc-i440fx-rhel7.0.0 \
    -drive file='/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/ISO/Win8.1/en_windows_8.1_preview_x86_dvd_2358833.iso',index=1,if=none,id=drive-ide0-0-0,media=cdrom,format=raw \
    -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0 \
    -drive file='/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/windows/winutils.iso',index=2,if=none,id=drive-ide0-0-1,media=cdrom,format=raw \
    -device ide-drive,bus=ide.0,unit=1,drive=drive-ide0-0-1 \
    -drive file='/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/windows/virtio-win.latest_prewhql.iso',index=3,if=none,id=drive-ide0-1-0,media=cdrom,format=raw \
    -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0 \
    -drive file='/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win8.1-32/answer.vfd',if=none,id=fdc0-0-0,media=disk,readonly=off,format=raw \
    -global isa-fdc.driveA=fdc0-0-0 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -spice port=3000,password=123456,addr=0,tls-port=3200,x509-dir=/tmp/spice_x509d,tls-channel=main,tls-channel=inputs,image-compression=auto_glz,zlib-glz-wan-compression=auto,streaming-video=all,agent-mouse=on,playback-compression=on,ipv4 \
    -vga qxl \
    -global qxl-vga.vram_size=33554432 \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=d,menu=off   \
    -device virtio-serial-pci,id=virtio-serial0 \
    -device intel-hda,id=intel-hda0 \
    -device hda-duplex,id=hda-duplex0 \
    -enable-kvm 
2.
3.

Actual results:
Win8.1-32 guest installation stuck before entering the installer

Expected results:
guest installation successful

Additional info:
1. processor	: 23
vendor_id	: GenuineIntel
cpu family	: 6
model		: 45
model name	: Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz
stepping	: 7
microcode	: 0x710
cpu MHz		: 2280.000
cache size	: 15360 KB
physical id	: 1
siblings	: 12
core id		: 5
cpu cores	: 6
apicid		: 43
initial apicid	: 43
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid
bogomips	: 4004.74
clflush size	: 64
cache_alignment	: 64
address sizes	: 46 bits physical, 48 bits virtual
power management:
Comment 1 CongLi 2013-10-24 05:08:02 EDT
Created attachment 815703 [details]
all debug file
Comment 3 CongLi 2013-10-24 05:12:01 EDT
I have attached all debug files which are generated by autotest, there is guest screendump, debug info and some system info. 

If there is any problem, please let me know, thanks.
Comment 4 xhan 2013-12-19 04:08:47 EST
met this problem on
kernel-3.10.0-61.el7.x86_64
qemu-kvm-1.5.3-21.el7.x86_64

How reproducible:
3/11

Host cpu info:
processor	: 3
vendor_id	: GenuineIntel
cpu family	: 6
model		: 23
model name	: Intel(R) Xeon(R) CPU           E5205  @ 1.86GHz
stepping	: 6
microcode	: 0x60f
cpu MHz		: 1861.944
cache size	: 6144 KB
physical id	: 3
siblings	: 2
core id		: 1
cpu cores	: 2
apicid		: 7
initial apicid	: 7
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm dca sse4_1 lahf_lm dtherm tpr_shadow vnmi flexpriority
bogomips	: 3723.64
clflush size	: 64
cache_alignment	: 64
address sizes	: 38 bits physical, 48 bits virtual
power management:
Comment 5 CongLi 2014-01-07 22:36:41 EST
Hit this bug w/ win2012r2 guest on version:

kernel-3.10.0-65.el7.x86_64
qemu-kvm-rhev-1.5.3-31.el7.x86_64
virtio-win-prewhql-0.1-74.iso

will attach the debug file.
Comment 6 CongLi 2014-01-07 22:39:12 EST
Created attachment 846921 [details]
all debug file - win2012r2 guest
Comment 7 Yan Vugenfirer 2014-01-14 09:30:29 EST
Is this hang reproducible without AHCI?

Best regards,
Yan.
Comment 8 CongLi 2014-01-15 00:11:43 EST
(In reply to Yan Vugenfirer from comment #7)
> Is this hang reproducible without AHCI?
> 
> Best regards,
> Yan.

Yes, it can be reproduced without AHCI.
In comment 5, win2012r2 guest used virtio_scsi instead of AHCI.

-drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,file=/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win2012r2-64-virtio.qcow2 \
-device scsi-hd,id=image1,drive=drive_image1 \ 

And I have attached the debug file which has the screendumps in comment 6.

If it is necessary, I will test Win8.1.i386 guest.

Thanks,
Cong
Comment 9 Yan Vugenfirer 2014-01-28 07:38:25 EST
Can you generate guest crash dump when the hang is happening?

Thanks,
Yan.
Comment 10 Ronen Hod 2014-01-28 07:48:19 EST
Mike,

Can you please try to reproduce, and isolate the cause for this issue.
I think that you dis not run into this issue.

Thanks, Ronen.
Comment 11 Mike Cao 2014-01-28 09:07:54 EST
(In reply to Ronen Hod from comment #10)
> Mike,
> 
> Can ou please try to reproduce, and isolate the cause for this issue.
> I think that you dis not run into this issue.
> 
> Thanks, Ronen.

I installed win8.1-32 guest without any virtio-win drivers for more than 10 times,did not hit any issue,but we find some hang issues during netkvm whql test even without e1000 driver.I will try virtio-scsi tomorrow
Comment 12 CongLi 2014-02-11 01:42:11 EST
(In reply to Yan Vugenfirer from comment #9)
> Can you generate guest crash dump when the hang is happening?
> 
> Thanks,
> Yan.

Hi Yan,

Can't get the dump file for the installation just didn't start, the guest doesn't have OS.

can hit this bug with win2012r2 and driver virtio-blk & virtio-net.

    -m 4096
    -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=threads,file=/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win2012r2-64-virtio.qcow2 \
    -device virtio-blk-pci,id=image1,drive=drive_image1,bootindex=0,bus=pci.0,addr=06 \
    -device virtio-net-pci,mac=9a:26:27:28:29:2a,id=idm9SL2r,netdev=id6u6Dn3,bus=pci.0,addr=07  \

# free -m
             total       used       free     shared    buffers     cached
Mem:         47897      21083      26814         12          1      16212
-/+ buffers/cache:       4869      43028
Swap:        24135          0      24135

Tested on version:
kernel-3.10.0-84.el7.x86_64
qemu-kvm-1.5.3-45.el7.x86_64
virtio-win-prewhql-0.1-74.iso

The cdrom(drive_cd1) rd_bytes just same.

10 mins ago:
(qemu) info blockstats 
drive_image1: rd_bytes=3072 wr_bytes=512 rd_operations=6 wr_operations=1 flush_operations=0 wr_total_time_ns=108504794 rd_total_time_ns=285716 flush_total_time_ns=0
drive_cd1: rd_bytes=221749248 wr_bytes=0 rd_operations=108276 wr_operations=0 flush_operations=0 wr_total_time_ns=0 rd_total_time_ns=2105619769 flush_total_time_ns=0
drive_winutils: rd_bytes=2048 wr_bytes=0 rd_operations=1 wr_operations=0 flush_operations=0 wr_total_time_ns=0 rd_total_time_ns=99709 flush_total_time_ns=0
drive_virtio: rd_bytes=2048 wr_bytes=0 rd_operations=1 wr_operations=0 flush_operations=0 wr_total_time_ns=0 rd_total_time_ns=97656 flush_total_time_ns=0
drive_fl: rd_bytes=0 wr_bytes=0 rd_operations=0 wr_operations=0 flush_operations=0 wr_total_time_ns=0 rd_total_time_ns=0 flush_total_time_ns=0

10 mins later:
(qemu) info blockstats 
drive_image1: rd_bytes=3072 wr_bytes=512 rd_operations=6 wr_operations=1 flush_operations=0 wr_total_time_ns=108504794 rd_total_time_ns=285716 flush_total_time_ns=0
drive_cd1: rd_bytes=221749248 wr_bytes=0 rd_operations=108276 wr_operations=0 flush_operations=0 wr_total_time_ns=0 rd_total_time_ns=2105619769 flush_total_time_ns=0
drive_winutils: rd_bytes=2048 wr_bytes=0 rd_operations=1 wr_operations=0 flush_operations=0 wr_total_time_ns=0 rd_total_time_ns=99709 flush_total_time_ns=0
drive_virtio: rd_bytes=2048 wr_bytes=0 rd_operations=1 wr_operations=0 flush_operations=0 wr_total_time_ns=0 rd_total_time_ns=97656 flush_total_time_ns=0
drive_fl: rd_bytes=0 wr_bytes=0 rd_operations=0 wr_operations=0 flush_operations=0 wr_total_time_ns=0 rd_total_time_ns=0 flush_total_time_ns=0

Will attach the CML of win2012r2.

If there is other info I can collect, feel free to tell me.

Thanks,
Cong
Comment 13 CongLi 2014-02-11 01:45:38 EST
Created attachment 861685 [details]
win2012r2 CML (virtio_blk and virtio_net)
Comment 32 ShupingCui 2014-12-08 00:05:30 EST
Reproduced on 7.1 host and qemu-kvm-rhev-1.5.3-60.el7ev.x86_64 when installed win2012r2 guest with virtio_scsi + e1000 + '-M rhel6.4.0'.

cmd line:
/usr/bin/qemu-kvm \
    -name 'virt-tests-vm1'  \
    -sandbox off  \
    -M rhel6.4.0  \
    -nodefaults  \
    -vga std \
    -device AC97,bus=pci.0,addr=03  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20141205-181541-JxBhINvj,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20141205-181541-JxBhINvj,server,nowait \
    -device isa-serial,chardev=serial_id_serial0  \
    -chardev socket,id=seabioslog_id_20141205-181541-JxBhINvj,path=/tmp/seabios-20141205-181541-JxBhINvj,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20141205-181541-JxBhINvj,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=04 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pci.0,addr=05 \
    -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,file=/mnt/nfs_images/win2012-64r2-virtio-scsi.qcow2 \
    -device scsi-hd,id=image1,drive=drive_image1 \
    -device e1000,mac=9a:f9:72:56:c3:83,id=idCguBvR,netdev=idOjY14q,bus=pci.0,addr=06  \
    -netdev tap,id=idOjY14q,fd=24  \
    -m 16384  \
    -smp 21,maxcpus=21,cores=5,threads=2,sockets=2  \
    -cpu 'SandyBridge',+kvm_pv_unhalt,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic,hv_time \
    -drive id=drive_cd1,if=none,snapshot=off,aio=native,media=cdrom,file=/home/kvm_autotest_root/iso/ISO/Win2012R2/en_windows_server_2012_r2_x64_dvd_2707946.iso \
    -device ide-cd,id=cd1,drive=drive_cd1,bus=ide.0,unit=0 \
    -drive id=drive_winutils,if=none,snapshot=off,aio=native,media=cdrom,file=/usr/local/autotest/tests/virt/shared/data/isos/windows/winutils.iso \
    -device ide-cd,id=winutils,drive=drive_winutils,bus=ide.0,unit=1 \
    -drive id=drive_unattended,if=none,snapshot=off,aio=native,media=cdrom,file=/usr/local/autotest/tests/virt/shared/data/images/win2012r2-64/autounattend.iso \
    -device ide-cd,id=unattended,drive=drive_unattended,bus=ide.1,unit=0 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -vnc :0  \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=d,menu=off \
    -enable-kvm
Comment 33 ShupingCui 2014-12-08 00:17:22 EST
Created attachment 965686 [details]
screenshot

"-M pc" not met this bug, seems met it with "-M rhel6.4.0" now.
Comment 34 CongLi 2014-12-08 01:34:52 EST
Hi Yan,

Could you have a look at this bug?

Thanks.
Comment 39 Yan Vugenfirer 2015-04-05 05:04:39 EDT
Hi,

Can you share please your autounattend.iso that was used to reproduce the bug?

Thanks.
Comment 40 Yan Vugenfirer 2015-04-05 07:55:10 EDT
Created attachment 1011109 [details]
Boot loader error 0x0000000A for -M rhel6.4.0
Comment 41 Yan Vugenfirer 2015-04-05 10:47:28 EDT
*** Bug 1209039 has been marked as a duplicate of this bug. ***
Comment 42 Yan Vugenfirer 2015-04-05 10:48:55 EDT
Currently reproducible with:

Command line:

/usr/libexec/qemu-kvm \
        -M pc \
        -nodefaults  \
        -vga std \
        -cpu 'SandyBridge',+sep \
        -enable-kvm \
        -m 4096\
        -smp 4,maxcpus=4,cores=2,threads=1,sockets=2 \
        -name RH-1022895 \
        -rtc base=localtime,clock=host,driftfix=slew \
        -device nec-usb-xhci,id=usb1,bus=pci.0,addr=0x4 \
        -drive file=/home/igord/rh/1022895/virtio-scsi.qcow2 \
        -netdev tap,id=hostnet0,script=/home/igord/vms/whql-ifup-e1000,ifname=e1000-net0 \
        -device virtio-net,netdev=hostnet0,id=net0,mac=52:54:00:51:51:51,bus=pci.0,addr=03 \
        \
        -boot order=cdn,once=d,menu=off \
        -drive id=drive_cd1,if=none,snapshot=off,aio=native,media=cdrom,file=/home/igord/rh/1022895/en_windows_8_1_enterprise_x86_dvd_2972289.iso \
        -device ide-cd,id=cd1,drive=drive_cd1,bus=ide.1,unit=0 \
        -drive id=drive_cd2,if=none,snapshot=off,aio=native,media=cdrom,file=/home/igord/rh/1022895/virtio-win-0.1-74.iso \
        -device ide-cd,id=cd2,drive=drive_cd2,bus=ide.1,unit=1 \
        \
        -k en-us \
        -vga std \
        \
        -chardev socket,id=abcde,path=/tmp/monitor-1022895,server,nowait \
        -mon chardev=abcde,mode=readline \
        \
        -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
        -vnc :0


Version-Release number of selected component (if applicable):
kernel.x86_64: 3.10.0-123.el7
qemu-kvm.x86_64: 10:1.5.3-60.el7
Comment 43 Yan Vugenfirer 2015-04-05 10:49:07 EDT
Currently reproducible with:

Command line:

/usr/libexec/qemu-kvm \
        -M pc \
        -nodefaults  \
        -vga std \
        -cpu 'SandyBridge',+sep \
        -enable-kvm \
        -m 4096\
        -smp 4,maxcpus=4,cores=2,threads=1,sockets=2 \
        -name RH-1022895 \
        -rtc base=localtime,clock=host,driftfix=slew \
        -device nec-usb-xhci,id=usb1,bus=pci.0,addr=0x4 \
        -drive file=/home/igord/rh/1022895/virtio-scsi.qcow2 \
        -netdev tap,id=hostnet0,script=/home/igord/vms/whql-ifup-e1000,ifname=e1000-net0 \
        -device virtio-net,netdev=hostnet0,id=net0,mac=52:54:00:51:51:51,bus=pci.0,addr=03 \
        \
        -boot order=cdn,once=d,menu=off \
        -drive id=drive_cd1,if=none,snapshot=off,aio=native,media=cdrom,file=/home/igord/rh/1022895/en_windows_8_1_enterprise_x86_dvd_2972289.iso \
        -device ide-cd,id=cd1,drive=drive_cd1,bus=ide.1,unit=0 \
        -drive id=drive_cd2,if=none,snapshot=off,aio=native,media=cdrom,file=/home/igord/rh/1022895/virtio-win-0.1-74.iso \
        -device ide-cd,id=cd2,drive=drive_cd2,bus=ide.1,unit=1 \
        \
        -k en-us \
        -vga std \
        \
        -chardev socket,id=abcde,path=/tmp/monitor-1022895,server,nowait \
        -mon chardev=abcde,mode=readline \
        \
        -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
        -vnc :0


Version-Release number of selected component (if applicable):
kernel.x86_64: 3.10.0-123.el7
qemu-kvm.x86_64: 10:1.5.3-60.el7
Comment 55 Gerd Hoffmann 2017-01-10 06:22:57 EST
Doesn't reproduce here.

Can anyone who has a machine where it happens please enable all usb_xhci_* tracepoints and attach the log?
Comment 56 Gerd Hoffmann 2017-03-14 03:42:13 EDT
Also: there have been a number of xhci fixes for 2.9,
please retest once 2.9 builds are available.
Comment 57 Ademar Reis 2017-05-09 08:13:31 EDT
(In reply to Gerd Hoffmann from comment #55)
> Doesn't reproduce here.
> 
> Can anyone who has a machine where it happens please enable all usb_xhci_*
> tracepoints and attach the log?

(In reply to Gerd Hoffmann from comment #56)
> Also: there have been a number of xhci fixes for 2.9,
> please retest once 2.9 builds are available.

Please retest (setting the right needinfo now)
Comment 58 CongLi 2017-05-10 01:43:22 EDT
Tested on:
qemu-kvm-rhev-2.9.0-3.el7.x86_64


1. There is no previous stuck issue now.

2. But met that Win8.1.32 could not apply the unattend answer's file's problem in windows setup with virtio-win-prewhql-0_1-136_i386.iso , screenshot will be attached.


Host info:
processor	: 23
vendor_id	: GenuineIntel
cpu family	: 6
model		: 45
model name	: Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz
stepping	: 7
microcode	: 0x710
cpu MHz		: 1573.515
cache size	: 15360 KB
physical id	: 1
siblings	: 12
core id		: 5
cpu cores	: 6
apicid		: 43
initial apicid	: 43
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm epb tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm ida arat pln pts
bogomips	: 4004.34
clflush size	: 64
cache_alignment	: 64
address sizes	: 46 bits physical, 48 bits virtual
power management:

Thanks.
Comment 59 CongLi 2017-05-10 01:45 EDT
Created attachment 1277497 [details]
screenshot - Win8.1.i386 could not apply unattend answer file - QEMU 2.9
Comment 60 Yan Vugenfirer 2017-05-10 07:10:41 EDT
(In reply to CongLi from comment #59)
> Created attachment 1277497 [details]
> screenshot - Win8.1.i386 could not apply unattend answer file - QEMU 2.9

Are you using same VM configuration or switched to virtio-block or virtio-scsi?
Comment 61 CongLi 2017-05-10 09:57:16 EDT
(In reply to Yan Vugenfirer from comment #60)
> (In reply to CongLi from comment #59)
> > Created attachment 1277497 [details]
> > screenshot - Win8.1.i386 could not apply unattend answer file - QEMU 2.9
> 
> Are you using same VM configuration or switched to virtio-block or
> virtio-scsi?


1. The hang problem was gone with previous configurations using ide.

2. For virtio_blk, it did not hang either before entering the installer, but there was the problem in attachment.


Thanks.
Comment 62 Yan Vugenfirer 2017-05-11 05:03:30 EDT
Do you use same answer file?

I think for virtio-block you need separate answer file, because now the storage driver is no longer Windows inbox driver.
Comment 63 CongLi 2017-05-15 10:31:50 EDT
(In reply to Yan Vugenfirer from comment #62)
> Do you use same answer file?
>
> I think for virtio-block you need separate answer file, because now the
> storage driver is no longer Windows inbox driver.

Thanks Yan for pointing it out, I did not describe it clearly.

For ide, using the same autoattend.iso as comment 51 but can not reproduce the previous issue now.

For virtio_blk, I used a different answer file for testing.


Host info:
processor	: 23
vendor_id	: GenuineIntel
cpu family	: 6
model		: 45
model name	: Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz
stepping	: 7
microcode	: 0x710
cpu MHz		: 2500.078
cache size	: 15360 KB
physical id	: 1
siblings	: 12
core id		: 5
cpu cores	: 6
apicid		: 43
initial apicid	: 43
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm epb tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm ida arat pln pts
bogomips	: 4004.81
clflush size	: 64
cache_alignment	: 64
address sizes	: 46 bits physical, 48 bits virtual
power management:


Thanks.
Comment 64 juzhang 2017-06-08 07:13:10 EDT
We had better update the flag from rhel-7.4.0 to rhel-7.5.0 if we do not plan to fix it in RHEL7.4
Comment 65 Yan Vugenfirer 2017-07-19 06:54:42 EDT
(In reply to CongLi from comment #63)
> (In reply to Yan Vugenfirer from comment #62)
> > Do you use same answer file?
> >
> > I think for virtio-block you need separate answer file, because now the
> > storage driver is no longer Windows inbox driver.
> 
> Thanks Yan for pointing it out, I did not describe it clearly.
> 
> For ide, using the same autoattend.iso as comment 51 but can not reproduce
> the previous issue now.
> 
> For virtio_blk, I used a different answer file for testing.
> 
> 
> Host info:
> processor	: 23
> vendor_id	: GenuineIntel
> cpu family	: 6
> model		: 45
> model name	: Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz
> stepping	: 7
> microcode	: 0x710
> cpu MHz		: 2500.078
> cache size	: 15360 KB
> physical id	: 1
> siblings	: 12
> core id		: 5
> cpu cores	: 6
> apicid		: 43
> initial apicid	: 43
> fpu		: yes
> fpu_exception	: yes
> cpuid level	: 13
> wp		: yes
> flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat
> pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb
> rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology
> nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx
> est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic popcnt
> tsc_deadline_timer aes xsave avx lahf_lm epb tpr_shadow vnmi flexpriority
> ept vpid xsaveopt dtherm ida arat pln pts
> bogomips	: 4004.81
> clflush size	: 64
> cache_alignment	: 64
> address sizes	: 46 bits physical, 48 bits virtual
> power management:
> 
> 
> Thanks.

Just to clarify the current status - so the issue is gone and the problem with answer file is fixed, I am right?
Comment 66 CongLi 2017-07-19 09:31:07 EDT
(In reply to Yan Vugenfirer from comment #65)
> 
> Just to clarify the current status - so the issue is gone and the problem
> with answer file is fixed, I am right?

Yes, according to my test, there is no issue now.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.