Bug 1022916 - Microsoft SQL servers don't support UTF-8
Microsoft SQL servers don't support UTF-8
Status: CLOSED DUPLICATE of bug 1018227
Product: JBoss Data Grid 6
Classification: JBoss
Component: Server (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Tristan Tarrant
Martin Gencur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 05:24 EDT by Jakub Markos
Modified: 2013-10-24 05:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-24 05:26:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Markos 2013-10-24 05:24:03 EDT
Please see https://bugzilla.redhat.com/show_bug.cgi?id=1018227 for more details, especially Martins comment: 
"Yeah, the Microsoft SQL server does not seem to support UTF-8. It means that for string-based cache stores only "String" can be used as a key. The other types (coverted with Key2StringMapper) cannot. AFAIK, it also means that string-based cache store cannot be used at all if data is stored via HotRod. That's because HotRod does not send plain strings."
Comment 1 Jakub Markos 2013-10-24 05:26:59 EDT
Sorry, this was a misunderstanding.

*** This bug has been marked as a duplicate of bug 1018227 ***

Note You need to log in before you can comment on or make changes to this bug.