Bug 1022920 - Can't click Add when configuring a SSH vpn in NetworkManager-ssh though NetworkManager
Can't click Add when configuring a SSH vpn in NetworkManager-ssh though Netwo...
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: NetworkManager-ssh (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Fruehauf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 05:26 EDT by Peter Robinson
Modified: 2014-09-02 05:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-02 05:40:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2013-10-24 05:26:37 EDT
When trying to add a SSH vpn using the NetworkManager UI in gnome3 once all the settings are in the Add button doesn't work
Comment 1 Dan Fruehauf 2013-10-27 02:46:29 EDT
(In reply to Peter Robinson from comment #0)
> When trying to add a SSH vpn using the NetworkManager UI in gnome3 once all
> the settings are in the Add button doesn't work

Thanks for reporting that. I'm in the process of configuring a f20 development environment and hope to address this as soon as possible.
Comment 2 Dan Fruehauf 2013-10-29 01:53:54 EDT
Unlike the rest of the NetworkManager plugins, NetworkManager-ssh actually separated itself to NetworkManager-ssh and NetworkManager-ssh-gnome.

I think if you install NetworkManager-ssh-gnome - you'll get the functionality you're looking for - the GUI for editing new/existing connections.
Comment 3 Peter Robinson 2013-10-29 05:13:21 EDT
(In reply to Dan Fruehauf from comment #2)
> Unlike the rest of the NetworkManager plugins, NetworkManager-ssh actually
> separated itself to NetworkManager-ssh and NetworkManager-ssh-gnome.
> 
> I think if you install NetworkManager-ssh-gnome - you'll get the
> functionality you're looking for - the GUI for editing new/existing
> connections.

Nope. I have the GUI for editing new connections via the gnome NM control panel. When I put in a server and various other settings in the GUI the Add button doesn't work.

# rpm -qa|grep NetworkManager-ssh
NetworkManager-ssh-0.9.1-0.5.20130706git6bf4649.fc20.x86_64
NetworkManager-ssh-gnome-0.9.1-0.5.20130706git6bf4649.fc20.x86_64
Comment 4 Dan Fruehauf 2013-10-30 06:45:57 EDT
(In reply to Peter Robinson from comment #3)
> (In reply to Dan Fruehauf from comment #2)
> > Unlike the rest of the NetworkManager plugins, NetworkManager-ssh actually
> > separated itself to NetworkManager-ssh and NetworkManager-ssh-gnome.
> > 
> > I think if you install NetworkManager-ssh-gnome - you'll get the
> > functionality you're looking for - the GUI for editing new/existing
> > connections.
> 
> Nope. I have the GUI for editing new connections via the gnome NM control
> panel. When I put in a server and various other settings in the GUI the Add
> button doesn't work.
> 
> # rpm -qa|grep NetworkManager-ssh
> NetworkManager-ssh-0.9.1-0.5.20130706git6bf4649.fc20.x86_64
> NetworkManager-ssh-gnome-0.9.1-0.5.20130706git6bf4649.fc20.x86_64

Just got f20 and installed NetworkManager-ssh and it seems to work well.

Can you please specify again the scenario you're running? There's no 'Add' button in the dialog, there's a 'Save...' button which works and saves the configuraiton.
Comment 5 Dan Fruehauf 2013-12-06 06:07:47 EST
(In reply to Dan Fruehauf from comment #4)
> (In reply to Peter Robinson from comment #3)
> > (In reply to Dan Fruehauf from comment #2)
> > > Unlike the rest of the NetworkManager plugins, NetworkManager-ssh actually
> > > separated itself to NetworkManager-ssh and NetworkManager-ssh-gnome.
> > > 
> > > I think if you install NetworkManager-ssh-gnome - you'll get the
> > > functionality you're looking for - the GUI for editing new/existing
> > > connections.
> > 
> > Nope. I have the GUI for editing new connections via the gnome NM control
> > panel. When I put in a server and various other settings in the GUI the Add
> > button doesn't work.
> > 
> > # rpm -qa|grep NetworkManager-ssh
> > NetworkManager-ssh-0.9.1-0.5.20130706git6bf4649.fc20.x86_64
> > NetworkManager-ssh-gnome-0.9.1-0.5.20130706git6bf4649.fc20.x86_64
> 
> Just got f20 and installed NetworkManager-ssh and it seems to work well.
> 
> Can you please specify again the scenario you're running? There's no 'Add'
> button in the dialog, there's a 'Save...' button which works and saves the
> configuraiton.

Hey there, any news with that? I couldn't reproduce your problem.
Comment 6 Peter Robinson 2014-04-14 08:36:23 EDT
Will test again this week once I've upgraded to F-21
Comment 7 Dan Fruehauf 2014-04-14 09:23:24 EDT
I'll be waiting to hear from you then! :)
Comment 8 Peter Robinson 2014-09-02 05:40:56 EDT
Closing for the moment, not using it

Note You need to log in before you can comment on or make changes to this bug.