Bug 1022955 - [RHSC] - Rebalance and remove brick buttons should be disabled until the data migration is in progress, after rebalance or remove-brick is stopped.
[RHSC] - Rebalance and remove brick buttons should be disabled until the data...
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Dusmant
RamaKasturi
:
Depends On:
Blocks: 1035040
  Show dependency treegraph
 
Reported: 2013-10-24 07:05 EDT by RamaKasturi
Modified: 2016-02-17 19:15 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Rebalance or Remove-brick, cannot be started immediately after stopping rebalance or remove-brick, when large file migration is in progress, as part of the previous operation (rebalance or remove-brick), even though it says it's stopped.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-31 05:53:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RamaKasturi 2013-10-24 07:05:09 EDT
Description of problem:
 After rebalance is stopped, if a file is still in migration, rebalance button should not be enabled

Version-Release number of selected component (if applicable):
rhsc-2.1.2-0.21.beta1.el6_4.noarch

How reproducible:
always

Steps to Reproduce:
1. create a volume and start rebalance on the volume.
2. Once rebalance is started, click on the status button.
3. Now click on stop rebalance from the rebalance status dialog.
4. 

Actual results:
After rebalance is stopped,When a file is still in migration,rebalance button gets enabled.

Expected results:
After rebalance is stopped,rebalance button should not be enabled until the file is completely migrated.

Additional info:
Comment 1 RamaKasturi 2013-10-24 07:07:31 EDT
once rebalance is stopped, status dialog also stops refreshing.
Comment 3 Dusmant 2013-10-25 02:49:54 EDT
This issue should be documented. Currently there is  no solution for this, till GLusterFS gives the status as "Aborting" till the last file migration is completed. Once it's done, it should show as "Aborted".
Comment 4 RamaKasturi 2013-12-11 03:32:26 EST
Steps to reproduce:

1) create a distribute volume and start it.
2) start rebalance on the volume and stop it.
3) Immediately after stop, try starting rebalance again.

Actual Results:

It gives an error saying "colud not start gluster volume <volName> rebalance" . This happens because, once rebalance stop command is issued, rebalance runs till the file under migration is completely done.

Expected Resutls:

User should not be able to start rebalance / rebalance should stop immediately once stop command is issued.
Comment 5 Shalaka 2014-01-23 04:23:36 EST
Please review the edited DocText and signoff.
Comment 6 Dusmant 2015-08-31 05:53:20 EDT
We are not planning to fix it. Hence closing this BZ. If you think, it's applicable for 3.x release and would have an impact on customer, pls. open up a new BZ with the appropriate version. Thanks, -Dusmant

Note You need to log in before you can comment on or make changes to this bug.