Bug 1022968 - Agent installed via RPM cannot discover storage
Agent installed via RPM cannot discover storage
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server (Show other bugs)
JON 3.2
x86_64 Linux
unspecified Severity high
: post-GA
: JON 3.2.0
Assigned To: Stefan Negrea
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 07:37 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-12 10:43:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Armine Hovsepyan 2013-10-24 07:37:29 EDT
Description of problem:
Agent installed via RPM cannot discover storage - leading to red error message on Administration -> Storage Nodes -> Cluster Alerts

Version-Release number of selected component (if applicable):
jon 3.2 er4

How reproducible:
always

Steps to Reproduce:
1. install and start  server and storage on IP1
2. install agent via rpm
3. start agent service
4. navigate to Administration -> Storage Nodes -> Cluster Alerts

Actual results:
After step 3. agent service started as jbosson-agent user (being created during agent rpm install) and cannot discover storage (started by any other user - cannot be installed/started by jbosson-agent)
After step4. Exception on ui -> http://d.pr/i/R4zn

Expected results:
After step 3. storage is discovered by agent?? 
After step4.  cluster alerts page displayed without errors? 


Additional info:
Comment 2 Stefan Negrea 2013-10-29 09:24:40 EDT
The scenario described above is not supported because the agent RPM is designed to be installed only on systems that have no JON server components. 

The actual results section of the initial report correctly points to the cause. The RPM agent is started with a different user than storage node user. The agent cannot discover the storage node because it does not have permission to view or access processes from other users. The agent RPM execution is downgraded on purpose to a non-root user to prevent these kind of scenarios where the agent has broad access to the system.


While the scenario described above is NOT supported here is a potential set of steps:
1) Install storage node via rhqctl 
2) rhqctl will automatically install an agent
3) Remove the agent installed by rhqctl
4) Install the agent RPM
5) Modify the agent RPM to run under the same user/group as the storage node (please see instructions above).

Again, the steps above are NOT supported because rhqctl is designed to install JON server and server related components while the agent RPM is designed to run on systems with no JON server components.

Here is the documentation on how run the agent RPM under a different user:
https://access.redhat.com/site/documentation/en-US/JBoss_Operations_Network/3.1/html/Installation_Guide/agent-rpms.html
Comment 4 Mike Foley 2013-12-09 11:58:32 EST
QE Deliverable is to update this testcase with information from this BZ ... and re-execute.

https://tcms.engineering.redhat.com/run/94976/?from_plan=6517
Comment 6 Stefan Negrea 2014-06-12 10:43:11 EDT
As mentioned in comment #2 , this issue is not valid. Closing per discussion with Mike Foley.

Note You need to log in before you can comment on or make changes to this bug.