Bug 1022979 - rhqctl status would never get/show (valid) information about agent installed via RPM (yum)
rhqctl status would never get/show (valid) information about agent installed ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Documentation (Show other bugs)
JON 3.2
x86_64 Linux
unspecified Severity high
: ER06
: JON 3.2.0
Assigned To: Deon Ballard
Mike Foley
: Documentation
Depends On:
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2013-10-24 07:53 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-24 12:57:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Armine Hovsepyan 2013-10-24 07:53:17 EDT
Description of problem:
rhqctl status would never get/show information about agent installed via RPM (yum)

Version-Release number of selected component (if applicable):
jon 3.2 er4

How reproducible:
always

Steps to Reproduce:
1. install storage and server via rhqctl
2. install agent via rpm
3. run rhqctl status
4. start agent service
5. run rhqctl status
6. run rhqctl status --agent

Actual results:
After step3 and step5 rhqctl doesn't have information about agnet
After step6 rhqctl shows agent is not installed and ignoring --agent option

Expected results:
rhqctl should be showing information about agent installed via rpm

Additional info:
Comment 1 Stefan Negrea 2013-10-29 09:36:31 EDT
The scenario described above is not supported because the agent RPM is designed to be installed only on systems that have no JON server components. At the same time, rhqctl is designed to install JON server and server related components. 

rhqctl cannot discover agents that are not installed by itself because of serveral reasons:
1) the agents can be anywhere on disk
2) the agents can installed and run under any other user


rhqctl is designed to only managed the agent that installs because it runs under the same username and knows the exact location of the installation. RPM installations or manual jar/zip installations using binaries downloaded from the server cannot be detected and will not be managed by rhqctl.


The scenario presented above is NOT supported.
Comment 2 Thomas Heute 2013-11-06 02:45:02 EST
Should we close it then ?
Comment 3 Deon Ballard 2013-11-08 01:39:53 EST
Stefan pointed out that this should be noted in the RPM install docs. I am stealing the bug.
Comment 4 Deon Ballard 2014-01-24 12:57:46 EST
So, there is a big note in the RPM install chapter that it is only for managed resources:
https://access.redhat.com/site/documentation/en-US/Red_Hat_JBoss_Operations_Network/3.2/html/Installation_Guide/agent-rpms.html

And I added Simeon's procedure for migrating an agent RPM to rhqctl for any installed on a server machine:
https://access.redhat.com/site/documentation/en-US/Red_Hat_JBoss_Operations_Network/3.2/html/Installation_Guide/rpm-upgrade.html#rpm-migrate-rhqctl

There's also a note in the agent JAR install chapter that it is for managed resources, not JON server platforms:
https://access.redhat.com/site/documentation/en-US/Red_Hat_JBoss_Operations_Network/3.2/html/Installation_Guide/Agent_Installation.html

Note You need to log in before you can comment on or make changes to this bug.