Bug 1022994 - dnf end up in endless loop if /var/cache is too small
dnf end up in endless loop if /var/cache is too small
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: librepo (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mlcoch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 08:19 EDT by Jiri Moskovcak
Modified: 2015-02-01 17:56 EST (History)
6 users (show)

See Also:
Fixed In Version: librepo-1.0.0-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-15 11:47:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Moskovcak 2013-10-24 08:19:08 EDT
Description of problem:
I have /var/cache mounted as tmpfs, as it turned out, it's not big enough when trying to install kernel-debug package and dnf keeps downloading it in an endless loop. Yum handles this situation gracefully and tells me there is not enough space.

Version-Release number of selected component (if applicable):
dnf-0.3.11-3.git7bdc9e1.fc19.noarch

How reproducible:
100%

Steps to Reproduce:
1. mount /var/cache  (in my case 512M)
2. try to install kernel-debug (or any other big package)
3. watch it loop!

Actual results:
endless loop

Expected results:
what yum does
Comment 1 Ales Kozumplik 2013-10-24 08:23:52 EDT
Zdenek this seems to be a download thing would you take a look? Thanks!
Comment 2 Jiri Moskovcak 2013-10-24 08:27:24 EDT
This is what yum says:

Error downloading packages:
  1:akmod-nvidia-325.15-1.fc19.1.x86_64: Insufficient space in download directory /var/cache/yum/x86_64/19/rpmfusion-nonfree-updates/packages
    * free   6.5 M
    * needed 8.3 M
  kernel-debug-devel-3.11.6-200.fc19.x86_64: Insufficient space in download directory /var/cache/yum/x86_64/19/updates/packages
    * free   6.5 M
    * needed 8.4 M
  1:xorg-x11-drv-nvidia-libs-325.15-1.fc19.x86_64: Insufficient space in download directory /var/cache/yum/x86_64/19/rpmfusion-nonfree-updates/packages
    * free   6.5 M
    * needed 21 M
Comment 3 Zdeněk Pavlas 2013-10-24 08:35:41 EDT
Yep, there's no free space check in dnf..  I wonder if we should add it, or just improve the error handling (that's mostly librepo stuff). 

In general, other programs might eat disk space just after we run the check, so it's not sufficient.
Comment 6 Ales Kozumplik 2014-02-03 04:24:37 EST
I guess this can be closed now, Tomas?
Comment 7 Fedora Update System 2014-02-03 06:24:12 EST
librepo-1.0.0-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/librepo-1.0.0-4.fc19
Comment 8 Fedora Update System 2014-02-03 21:45:58 EST
Package librepo-1.0.0-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing librepo-1.0.0-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-1971/librepo-1.0.0-4.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2014-04-15 11:47:39 EDT
librepo-1.0.0-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.