Bug 10230 - ppp-watch broken
Summary: ppp-watch broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-19 00:01 UTC by Mikhail Zabaluev
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-20 16:04:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here's that PPP patch (2.10 KB, patch)
2000-03-19 00:03 UTC, Mikhail Zabaluev
no flags Details | Diff

Description Mikhail Zabaluev 2000-03-19 00:01:01 UTC
The ppp-watch code in initscripts 4.72 has serious flaws that disable
normal usage of /sbin/ifup and /sbin/ifdown for PPP connections.
I'm using Mandrake and their packages, but it seems like the
problem is on your behalf.
First, it erroneously expects a return status from socket() to be non-zero
for success (actually it have to be non-negative)
when it checks whether an interface is up; this error stops ifup from a
successful return even when a connection is successfully established.
Second, closing the standard descriptors and executing a shell script
afterwards is a bad idea, since that shell runs into problems, for example,
when doing a pipe. You may consider to use /dev/null instead.

I have made a patch that solves both issues, and additionally removes
'--remotename' option from parameters that wvdial is issued with
by ifup-ppp script - the version of wvdial on my system doesn't recognize
it, and it can be placed in /etc/wvdial.conf instead.
Email me if you wanna take a look at the patch.

Comment 1 Mikhail Zabaluev 2000-03-19 00:03:59 UTC
Created attachment 157 [details]
Here's that PPP patch

Comment 2 Bill Nottingham 2000-03-20 15:45:59 UTC
The return code of socket() has been fixed as of
the current rawhide release.

Comment 3 Bill Nottingham 2000-03-20 16:04:59 UTC
ppp-watch is changed to open /dev/null as of initscripts-5.02.


Note You need to log in before you can comment on or make changes to this bug.