Bug 1023035 - [RHEVM] [webadmin] [UI] not enough space for nic10 in New Virtual Machine dialog
[RHEVM] [webadmin] [UI] not enough space for nic10 in New Virtual Machine dialog
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
x86_64 Linux
low Severity low
: ---
: 3.3.0
Assigned To: Lior Vernia
Martin Pavlik
network
: Triaged
Depends On:
Blocks: 3.3snap2
  Show dependency treegraph
 
Reported: 2013-10-24 09:33 EDT by Martin Pavlik
Modified: 2016-02-10 14:53 EST (History)
10 users (show)

See Also:
Fixed In Version: is22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 02:04:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot 1 (194.96 KB, image/png)
2013-10-24 09:33 EDT, Martin Pavlik
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20594 None None None Never

  None (edit)
Description Martin Pavlik 2013-10-24 09:33:58 EDT
Created attachment 815786 [details]
screenshot 1

Description of problem:
if more than 9 vNICs are added in New Virtual Machine dialog "+" button jumps from right side of profile drop down menu bellow it (see screenshot)


Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.3.0-0.26.master.el6ev 

How reproducible:
100%

Steps to Reproduce:
1. Virtual Machines -> New VM
2. add 10 vNICs 
3.

Actual results:
"+" button jumps from right side of profile drop down menu bellow it

Expected results:
 "+" stays on right side

Additional info:
Comment 1 Moti Asayag 2013-10-27 04:48:17 EDT
I'm not sure how common is vm with 10 nics in real life, but the fix for it shouldn't be an easy one.
Comment 2 Lior Vernia 2013-10-27 05:17:12 EDT
With the fix for Bug 1012798 (soon to be merged in RHEV), the line no longer breaks. However, the UI fields are more indented compared to preceding rows due to the length of "nicXX" compared to "nicX", and this probably merits a fix as well.
Comment 3 Shai Revivo 2013-11-10 02:04:56 EST
This bug was fixed and is slated to be in the upcoming version. As we are focusing our testing at this phase on severe bugs, this bug was closed without going through its verification step.

Note You need to log in before you can comment on or make changes to this bug.