Bug 1023089 - All references to "RedHat" in foreman need to be fixed for appropriate branding!
All references to "RedHat" in foreman need to be fixed for appropriate branding!
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Greg Sutcliffe
Tazim Kolhar
http://projects.theforeman.org/issues...
: Tracking, Triaged
Depends On:
Blocks: 987537 1042862 1045059
  Show dependency treegraph
 
Reported: 2013-10-24 11:11 EDT by Corey Welton
Modified: 2016-04-22 12:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: foreman-1.3.0-29.el6sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-11 08:25:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 3723 None None None 2016-04-22 12:46 EDT

  None (edit)
Description Corey Welton 2013-10-24 11:11:28 EDT
Description of problem:
In some places across the foreman UI, but most notably "operating systems", there are a bunch of references to "RedHat" or "Redhat"  --  'RedHat Server', OS type of 'Redhat', partition table type of 'RedHat default'.  These all need to be updated per Red Hat trademark usage guidelines

We can use this as a tracking bug if so desired -- as I noted, Operating Systems page is the biggest offender, but I am sure it is referenced elsewhere in the UI as well.
Comment 1 Dominic Cleal 2013-10-24 11:15:23 EDT
I think a tracker would be useful as some of these will be much harder than others so we'd want to tackle them separately.  Please file additional bugs for specific instances if you wouldn't mind.  The operating system is particularly tricky because the name comes from Facter.

I agree wholeheartedly though, I'd really like to fix these.
Comment 3 Dominic Cleal 2013-10-25 09:30:22 EDT
Not creating upstream bugs until we can break this down a bit.
Comment 4 Dominic Cleal 2013-11-22 04:46:17 EST
Created a tracker upstream with three issues I'm aware of - OS names, OS families, default partition table name, and a few bits of UI text.  If you spot any more, please comment here.
Comment 8 Tazim Kolhar 2014-08-11 05:36:40 EDT
VERIFIED
Comment 9 Tazim Kolhar 2014-08-12 02:10:25 EDT
# rpm -qa | grep foreman
ruby193-rubygem-foreman-redhat_access-0.0.4-1.el6sat.noarch
ruby193-rubygem-foreman_discovery-1.3.0-2.el6sat.noarch
foreman-libvirt-1.6.0.38-1.el6sat.noarch
foreman-compute-1.6.0.38-1.el6sat.noarch
ruby193-rubygem-foreman_bootdisk-2.0.6-1.1.el6sat.noarch
foreman-1.6.0.38-1.el6sat.noarch
foreman-ovirt-1.6.0.38-1.el6sat.noarch
foreman-selinux-1.6.0.4-1.el6sat.noarch
foreman-gce-1.6.0.38-1.el6sat.noarch
ruby193-rubygem-foreman_hooks-0.3.5-2.el6sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3-3.el6sat.noarch
foreman-proxy-1.6.0.23-1.el6sat.noarch
qetello02.usersys.redhat.com-foreman-proxy-1.0-1.noarch
foreman-vmware-1.6.0.38-1.el6sat.noarch
rubygem-hammer_cli_foreman-0.1.1-15.el6sat.noarch
foreman-postgresql-1.6.0.38-1.el6sat.noarch
ruby193-rubygem-foreman-tasks-0.6.6-2.el6sat.noarch
qetello02.usersys.redhat.com-foreman-client-1.0-1.noarch

Operating Systems in UI updated
Comment 11 Bryan Kearney 2014-09-11 08:25:32 EDT
This was delivered with Satellite 6.0 which was released on 10 September 2014.

Note You need to log in before you can comment on or make changes to this bug.