Bug 1023109 - ksh stops on read when monitor mode is enabled
Summary: ksh stops on read when monitor mode is enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ksh
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michal Hlavinka
QA Contact: Martin Kyral
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-10-24 15:52 UTC by Michal Hlavinka
Modified: 2014-10-14 07:04 UTC (History)
2 users (show)

Fixed In Version: ksh-20120801-16.el6
Doc Type: Bug Fix
Doc Text:
Ksh set wrong process group when monitor mode was enabled when running a script. As a consequence when such script tried to read an input, the process stopped execution. This updated version was fixed to use correct process group and the script execution no longer stops in above described scenario.
Clone Of:
: 1023110 (view as bug list)
Environment:
Last Closed: 2014-10-14 07:04:14 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch to fix this (493 bytes, patch)
2013-10-24 15:52 UTC, Michal Hlavinka
no flags Details | Diff
patch to fix this v2 (559 bytes, patch)
2014-01-23 14:30 UTC, Michal Hlavinka
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1381 0 normal SHIPPED_LIVE ksh bug fix update 2014-10-14 01:28:24 UTC

Description Michal Hlavinka 2013-10-24 15:52:16 UTC
Created attachment 815839 [details]
patch to fix this

Version-Release number of selected component (if applicable):
ksh-20120801-10.el6

How reproducible:
always

Steps to Reproduce:
ksh -c 'set -m; /bin/echo before; read a; echo /bin/after'


Actual results:
before
[1]+  Stopped   ksh -c 'set -m; /bin/echo before; read a; echo /bin/after'

Expected results:
before
aaa<return>
after

Comment 2 Michal Hlavinka 2014-01-23 14:30:13 UTC
Created attachment 854418 [details]
patch to fix this v2

Comment 5 errata-xmlrpc 2014-10-14 07:04:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1381.html


Note You need to log in before you can comment on or make changes to this bug.