Bug 1023140 - Gnome Shell extensions don't reactivate after lock-screen
Gnome Shell extensions don't reactivate after lock-screen
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
20
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 13:21 EDT by Dominik Grafenhofer
Modified: 2014-02-20 10:45 EST (History)
8 users (show)

See Also:
Fixed In Version: gnome-shell-3.10.2.1-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-13 22:37:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 688331 None None None Never

  None (edit)
Description Dominik Grafenhofer 2013-10-24 13:21:40 EDT
The following Gnome-shell extensions don't reactivate after lock-screen:
Places Status Indicator
Messaging Menu
Drop Down Terminal

Not affected: Weather

How reproducible: Always

Steps to Reproduce:

1. Add mentioned extensions to gnome-shell
2. Wait for lock screen to appear (or lock the screen manually)
3. After unlocking the screen these extensions are gone
4. Restarting gnome-shell (ALT-F4 + typing r) brings back the extensions

See upstream bug for screen shots.

I am running F-20 alpha incl. all updates
Comment 1 Rick 2013-11-27 07:28:15 EST
Just adding that this is not limited to Fedora, I have the same issue in openSUSE 13.1 w/ Gnome 3.10 HOWEVER, on my system ALL my extensions are disabled - including Weather...
Comment 2 Rick 2013-11-27 14:13:15 EST
Also, I just tested the patch on gnome bugzilla and it does seem to fix the problem.
Comment 3 Jason Haar 2013-11-27 17:16:28 EST
I have also seen this under F20 last week, and just today after a big lot of updates came through. I updated and the system rebooted as part of the process (ie I "drank the Fedora cool aid" and did the entire process as instructed). After the reboot I logged in and ALL extensions were disabled. I then went to extensions.gnome.org and saw they were all disabled. I simply turned each one back on and they are all fine again. 

So there's nothing wrong with the extensions, gnome is doing something weird there...

Jason
Comment 4 Florian Müllner 2013-11-28 07:17:10 EST
(In reply to Rick from comment #1)
> Just adding that this is not limited to Fedora, I have the same issue in
> openSUSE 13.1 w/ Gnome 3.10

Yes, see the linked upstream bug above. I'm currently preparing a Fedora update with the backported upstream fix, you could ask the OpenSUSE developers to do the same (or wait for another 3.10.x release that might happen at some point).


> HOWEVER, on my system ALL my extensions are disabled - including Weather...

Well, the issue is that after on exceptions throws an error when re-enabled, no further extension is enabled. So in your case an error is thrown before enabling Weather, while for the original reporter it happened after that.


(In reply to Jason Haar from comment #3)
> So there's nothing wrong with the extensions

No, that's not correct. Assuming this is the same issue, the problem of not (re-)enabling extensions once an error is thrown is a GNOME issue, but there has to be *some* extension error to trigger it.

One possible why manually enabling extenions works for you may be a different extension order (if two extensions touch the same UI, but only one extension is prepared to deal with the modifications done by the other).
Comment 5 Fedora Update System 2013-11-28 07:27:10 EST
gnome-shell-3.10.2.1-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gnome-shell-3.10.2.1-3.fc20
Comment 6 Fedora Update System 2013-11-29 11:02:04 EST
Package gnome-shell-3.10.2.1-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-shell-3.10.2.1-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22387/gnome-shell-3.10.2.1-3.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-12-13 22:37:04 EST
gnome-shell-3.10.2.1-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Marvin Clavey 2014-02-19 12:54:24 EST
I am on Fedora/Korora 20 gnome shell 3.10.3 and I still have this problem 
Hp laptop ... when I close the cover and reopen it and logon again the extensions are gone .
Comment 9 Florian Müllner 2014-02-20 10:45:53 EST
(In reply to Marvin Clavey from comment #8)
> I am on Fedora/Korora 20 gnome shell 3.10.3 and I still have this problem 
> Hp laptop ... when I close the cover and reopen it and logon again the
> extensions are gone .

What extensions? And are there any relevant errors in the journal (something like "journalctl _SYSTEMD_SESSION=$XDG_SESSION_ID -b")?
An extension that fails when disabled/re-enabled is not something we can fix, all we can do is make sure that an error in one extension doesn't interfere with other extensions (that's basically what the update was about)

Note You need to log in before you can comment on or make changes to this bug.