Bug 1023148 - compression time metrics are not getting updated
compression time metrics are not getting updated
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity medium
: ER05
: JON 3.2.0
Assigned To: John Sanda
Mike Foley
:
Depends On: 1022775
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2013-10-24 13:38 EDT by John Sanda
Modified: 2014-01-02 15:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1022775
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (51.86 KB, image/png)
2013-11-12 08:51 EST, Sunil Kondkar
no flags Details

  None (edit)
Description John Sanda 2013-10-24 13:38:55 EDT
+++ This bug was initially created as a clone of Bug #1022775 +++

Description of problem:
One of the metrics reported by the Measurement Subsystem component of the RHQ Server resource is compression time. The metric always reports a value of zero due to a regression. MeasurementMonitorMBean.incrementMeasurementCompressionTime() is not getting called. It was called by MeasurementCompressionManagerBean; however, that class no longer performs the compression. It is now done by MetricsServer which should call the incrementMeasurementCompressionTime method. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 John Sanda 2013-10-24 21:51:14 EDT
Fix has been committed to the release/jon3.2.x branch.

commit hash: efa81f784
Comment 2 Simeon Pinder 2013-11-06 21:18:31 EST
Moving to ON_QA for test with new brew build.
Comment 3 Sunil Kondkar 2013-11-12 08:50:40 EST
Verified on version :3.2.0.ER5 Build Number : 2cb2bc9:225c796

The compression time metrics of RHQ Server Measurement Subsystem displays values. Please refer the screenshot.
Comment 4 Sunil Kondkar 2013-11-12 08:51:37 EST
Created attachment 822989 [details]
Screenshot

Note You need to log in before you can comment on or make changes to this bug.