Bug 1023164 - hammer: --help results should be a little more contextual for some commands
hammer: --help results should be a little more contextual for some commands
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Martin Bacovsky
Kedar Bidarkar
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 14:59 EDT by Corey Welton
Modified: 2016-04-22 12:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:07:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 3512 None None None 2016-04-22 12:32 EDT

  None (edit)
Description Corey Welton 2013-10-24 14:59:25 EDT
Description of problem:
Lots of the help results for 'location' should have text that is a little more applicable to the specified subcommand.

Version-Release number of selected component (if applicable):
Satellite-6.0.2-RHEL-6-20131023.1


How reproducible:


Steps to Reproduce:
1.  hammer -u admin -p admin location --help


Actual results:
Usage:
    hammer location [OPTIONS] SUBCOMMAND [ARG] ...

Parameters:
    SUBCOMMAND                    subcommand
    [ARG] ...                     subcommand arguments

Subcommands:
    remove_medium                 Disassociate a resource
    remove_configtemplate         Disassociate a resource
    remove_environment            Disassociate a resource
    remove_smartproxy             Disassociate a resource
    add_computeresource           Associate a resource
    list                          List all locations
    add_medium                    Associate a resource
    add_configtemplate            Associate a resource
    update                        Update a location
    add_environment               Associate a resource
    remove_subnet                 Disassociate a resource
    remove_organization           Disassociate a resource
    remove_domain                 Disassociate a resource
    remove_user                   Disassociate a resource
    delete                        Delete a location
    remove_hostgroup              Disassociate a resource
    add_smartproxy                Associate a resource
    add_subnet                    Associate a resource
    add_organization              Associate a resource
    add_domain                    Associate a resource
    add_user                      Associate a resource
    create                        Create a location
    add_hostgroup                 Associate a resource
    remove_computeresource        Disassociate a resource
    info                          Show a location



Expected results:
Usage:
    hammer location [OPTIONS] SUBCOMMAND [ARG] ...

Parameters:
    SUBCOMMAND                    subcommand
    [ARG] ...                     subcommand arguments

Subcommands:
    remove_medium                 Disassociate a medium
    remove_configtemplate         Disassociate a configuration template
    remove_environment            Disassociate an environment
    remove_smartproxy             Disassociate a smart proxy
    add_computeresource           Associate a compute resource
    list                          List all locations
    [...]

...and so on.  Likewise for the "Associate a resource" lines.


Additional info:
Comment 1 Corey Welton 2013-10-24 15:02:05 EDT
This needs to be done for 'organization --help' as well.
Comment 2 Corey Welton 2013-10-24 15:04:23 EDT
Others that need a little love

os --help
template --help
partition_table --help
Comment 8 Bryan Kearney 2014-06-04 08:04:42 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/3512 has been closed
Comment 10 Kedar Bidarkar 2014-06-06 08:50:05 EDT
[root@xxxxx ~]# hammer organization --help
Usage:
    hammer organization [OPTIONS] SUBCOMMAND [ARG] ...

Parameters:
    SUBCOMMAND                    subcommand
    [ARG] ...                     subcommand arguments

Subcommands:
    add-compute-resource          Associate a compute resource
    add-config-template           Associate a configuration template
    add-domain                    Associate a domain
    add-environment               Associate an environment
    add-hostgroup                 Associate a hostgroup
    add-medium                    Associate a medium
    add-smart-proxy               Associate a smart proxy
    add-subnet                    Associate a subnet
    add-user                      Associate an user
    create                        Create organization
    delete                        Delete an organization
    info                          Show organization
    list                          List all organizations
    remove-compute-resource       Disassociate a compute resource
    remove-config-template        Disassociate a configuration template
    remove-domain                 Disassociate a domain
    remove-environment            Disassociate an environment
    remove-hostgroup              Disassociate a hostgroup
    remove-medium                 Disassociate a medium
    remove-smart-proxy            Disassociate a smart proxy
    remove-subnet                 Disassociate a subnet
    remove-user                   Disassociate an user
    update                        Update organization

Options:
    -h, --help                    print help
[root@xxxxx ~]# hammer location --help
Usage:
    hammer location [OPTIONS] SUBCOMMAND [ARG] ...

Parameters:
    SUBCOMMAND                    subcommand
    [ARG] ...                     subcommand arguments

Subcommands:
    add-compute-resource          Associate a compute resource
    add-config-template           Associate a configuration template
    add-domain                    Associate a domain
    add-environment               Associate an environment
    add-hostgroup                 Associate a hostgroup
    add-medium                    Associate a medium
    add-organization              Associate an organization
    add-smart-proxy               Associate a smart proxy
    add-subnet                    Associate a subnet
    add-user                      Associate an user
    create                        Create a location
    delete                        Delete a location
    info                          Show a location
    list                          List all locations
    remove-compute-resource       Disassociate a compute resource
    remove-config-template        Disassociate a configuration template
    remove-domain                 Disassociate a domain
    remove-environment            Disassociate an environment
    remove-hostgroup              Disassociate a hostgroup
    remove-medium                 Disassociate a medium
    remove-organization           Disassociate an organization
    remove-smart-proxy            Disassociate a smart proxy
    remove-subnet                 Disassociate a subnet
    remove-user                   Disassociate an user
    update                        Update a location

Options:
    -h, --help                    print help





verified with sat6-snap8-compose2


* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.7-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.7-1.el6_5.noarch
* candlepin-tomcat6-0.9.7-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.14-1.el6sat.noarch
* foreman-compute-1.6.0.14-1.el6sat.noarch
* foreman-gce-1.6.0.14-1.el6sat.noarch
* foreman-libvirt-1.6.0.14-1.el6sat.noarch
* foreman-ovirt-1.6.0.14-1.el6sat.noarch
* foreman-postgresql-1.6.0.14-1.el6sat.noarch
* foreman-proxy-1.6.0.6-1.el6sat.noarch
* foreman-selinux-1.6.0-4.el6sat.noarch
* foreman-vmware-1.6.0.14-1.el6sat.noarch
* katello-1.5.0-25.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.5-1.el6sat.noarch
* katello-installer-0.0.45-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.18.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.18.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.18.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.18.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.18.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.18.beta.el6sat.noarch
* pulp-server-2.4.0-0.18.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* rubygem-hammer_cli-0.1.1-3.el6sat.noarch
* rubygem-hammer_cli_foreman-0.1.1-8.el6sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.3-2.el6sat.noarch
* rubygem-hammer_cli_katello-0.0.4-5.el6sat.noarch
Comment 11 Bryan Kearney 2014-07-02 10:07:33 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Note You need to log in before you can comment on or make changes to this bug.