Bug 1023192 - FSError: filesystem already exists
FSError: filesystem already exists
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-blivet (Show other bugs)
7.0
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: David Lehman
Release Test Team
abrt_hash:4cef3b27011be6b42a02f849aba...
: Reopened
: 1036256 (view as bug list)
Depends On: 1012504
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 16:29 EDT by David Lehman
Modified: 2014-06-18 00:44 EDT (History)
7 users (show)

See Also:
Fixed In Version: python-blivet-0.18.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1012504
Environment:
Last Closed: 2014-06-13 09:17:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2013-10-24 16:29:54 EDT
+++ This bug was initially created as a clone of Bug #1012504 +++

Description of problem:
Many attempts to get the layout I wanted in Manual partitioning, followed by Reset All, followed by another attempt. Installation had begun, and then installer crashed while creating ext4 on /dev/sda6.

Version-Release number of selected component:
anaconda-20.18-1.fc20.x86_64

The following was filed automatically by anaconda:
anaconda 20.18-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 779, in create
    raise FSError("filesystem already exists")
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 471, in execute
    options=self.device.formatArgs)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 310, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 142, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
FSError: filesystem already exists

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-Desktop-x86_64-20-Al ro rd.live.image quiet rhgb
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
other involved packages: python-libs-2.7.5-7.fc20.x86_64, python-blivet-0.20-1.fc20.noarch
product:        Fedora
release:        Fedora release 20 (Heisenbug)
type:           anaconda
version:        20

--- Additional comment from Reartes Guillermo on 2013-10-20 19:26:24 EDT ---

Here are the most simple steps to reproduce it. 

0. Boot Fedora 20b TC5 (no kernel parameter, either on a new guest or on an unpartitioned disk)

1. Reach the Welcome Hub (either use the default -English- or select your language -mine is Spanish-)

2. Leave defaults for Date & Time, Language Support, Keyboard, Installation Source, Software Selection, Network Configuration.

3. Enter Installation Destination Spoke.

4. The single disk is already selected. Press 'done'

5. On Installation Options Dialog, choose to do custom/manual partitioning ("I want to review...") and select 'btrfs' for the Partition Scheme, then 'Continue'.

6. Click '+' add '/boot' of '512'

7. Click '+' add 'swap' of '512'

9. Click '+' add '/' of <null>, anaconda will select the maximum size (as intended).

10. Press 'done' to return to the Main Hub.

11. Press 'Accept Changes' in 'Summary Of Changes' dialog. 
    There it can be seen (among other entries):
    * Create Format btrfs           vda3
    * Create Device btrfs volume    fedora
    * Create Format btrfs           fedora
    * Create Device btrfs subvolume root   <<< HERE
    * Create Format ext4            root   <<< HERE

12. In the Main Hub, Start Installing, an 'unknown error' will popup.
Comment 2 David Lehman 2013-12-04 15:47:43 EST
*** Bug 1036256 has been marked as a duplicate of this bug. ***
Comment 4 Ludek Smid 2014-06-13 09:17:00 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.