Bug 1023211 - OpenGL renderer == llvmpipe on NVIDIA Corporation G98 [Quadro NVS 420] [10de:06f8]
OpenGL renderer == llvmpipe on NVIDIA Corporation G98 [Quadro NVS 420] [10de:...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
20
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 17:47 EDT by Dan Young
Modified: 2015-06-29 08:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-29 08:43:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (39.17 KB, text/x-log)
2013-10-24 17:47 EDT, Dan Young
no flags Details
'lspci -nn' output (5.52 KB, text/plain)
2013-10-24 17:48 EDT, Dan Young
no flags Details
glxinfo &> /var/tmp/glxinfo (18.02 KB, text/plain)
2013-10-24 17:53 EDT, Dan Young
no flags Details
LIBGL_DEBUG=verbose glxinfo &> /var/tmp/glxinfo_LIBGL_DEBUG (18.98 KB, text/plain)
2013-10-24 18:14 EDT, Dan Young
no flags Details
'journalctl -a' after booting w/ drm.debug=15 (1.93 MB, text/plain)
2013-10-24 18:21 EDT, Dan Young
no flags Details

  None (edit)
Description Dan Young 2013-10-24 17:47:02 EDT
Created attachment 815935 [details]
Xorg.0.log

Description of problem:
OpenGL renderer is llvmpipe on NVIDIA Quadro NVS 420

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-1.0.9-2.fc20.i686

How reproducible:
always

Steps to Reproduce:
1. boot this livecd: http://fedorapeople.org/groups/qa/201310-Graphics_Test-mini-x86_64.iso
2. glxinfo | grep renderer

Actual results:
[liveuser@localhost ~]$ glxinfo | grep renderer
nv50_screen_create:624 - nouveau_screen_init failed: -12
libGL error: failed to load driver: nouveau
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 128 bits)


Expected results:
nouveau renderer

Additional info:
[liveuser@localhost ~]$ lspci -nn | grep VGA
04:00.0 VGA compatible controller [0300]: NVIDIA Corporation G98 [Quadro NVS 420] [10de:06f8] (rev a1)

No /etc/X11/xorg.conf used.

/var/log/Xorg.0.log attached.

Three monitors attached, though third doesn't work w/o booting with nouveau.modeset=0. I did NOT boot with that kernel param for this test day / bug report.
Comment 1 Dan Young 2013-10-24 17:48:30 EDT
Created attachment 815936 [details]
'lspci -nn' output
Comment 2 Dan Young 2013-10-24 17:53:01 EDT
Created attachment 815937 [details]
glxinfo &> /var/tmp/glxinfo

First three lines are stderr output.
Comment 3 Dan Young 2013-10-24 18:14:47 EDT
Created attachment 815940 [details]
LIBGL_DEBUG=verbose glxinfo &> /var/tmp/glxinfo_LIBGL_DEBUG
Comment 4 Dan Young 2013-10-24 18:21:50 EDT
Created attachment 815942 [details]
'journalctl -a' after booting w/ drm.debug=15
Comment 5 Dan Young 2013-10-24 19:00:41 EDT
Per adamw's recommendation ("odd selinux errors in there") in #fedora-test-day, I booted with 'enforcing=0' and checked glxinfo again.

[liveuser@localhost ~]$ glxinfo | grep renderer
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 128 bits)
[liveuser@localhost ~]$ sestatus 
SELinux status:                 enabled
SELinuxfs mount:                /sys/fs/selinux
SELinux root directory:         /etc/selinux
Loaded policy name:             targeted
Current mode:                   permissive
Mode from config file:          permissive
Policy MLS status:              enabled
Policy deny_unknown status:     allowed
Max kernel policy version:      28
[liveuser@localhost ~]$
Comment 6 Dan Young 2013-10-24 19:54:45 EDT
Just noticed that the installed nouveau is:
xorg-x11-drv-nouveau-1.0.9-2.fc20.i686

So I downloaded and ran the i686 ISO, not the x86_64 one.

Just tried the x86_64 ISO and renderer is "Gallium 0.4 on NV98". Sorry for the oops on my part...

Please comment if this bug is worth pursuing based on the i686 behavior.
Comment 7 Adam Williamson 2013-10-24 21:54:02 EDT
Um, yeah, I would still expect the 32-bit ISO to have working 3D acceleration. It's odd that it doesn't. I didn't actually test any of the ISOs on bare metal before publishing them, so it's possible there's some kind of bug in the ISO rather than in any of the packages, but both 32-bit and 64-bit images were generated from the same kickstart and repo (literally the sole difference in their generation is that I ran 'livecd-creator blahblah' to build the x86_64 ones, and 'linux32 livecd-creator blahblah' to build the i686 ones). I'll try and find a few minutes to boot them on metal here and see if I can reproduce the result, but I've got Beta TC5 validation to be working on too :/
Comment 8 Fedora End Of Life 2015-05-29 05:37:56 EDT
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 9 Fedora End Of Life 2015-06-29 08:43:08 EDT
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.