Bug 1023216 - (TEIIDDES-1897) Teiid Connection Importer is using the pool-name instead of jndi name
Teiid Connection Importer is using the pool-name instead of jndi name
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Tooling (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ER4
: 6.0
Assigned To: jolee
: Reopened
Depends On:
Blocks: 1064360
  Show dependency treegraph
 
Reported: 2013-10-24 18:24 EDT by Van Halbert
Modified: 2016-01-06 06:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When using the "Teiid Connection" importer in Teiid Designer, the data sources are identified with "pool-name" rather than the "jndi" name. This is the result of the AdminAPI getDataSourceNames() method returning the wrong one.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-06 06:59:31 EST
Type: Support Patch
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
How it looks in JBDS-IS 7.0.2.GA (234.89 KB, image/png)
2014-07-02 02:26 EDT, Andrej Podhradsky
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-2712 Major Closed AdminAPI getDataSourceNames is returning the pool name instead of jndi name 2016-01-06 10:48 EST
JBoss Issue Tracker TEIIDDES-1897 Major Closed Teiid Connection Importer is using the pool-name instead of jndi name 2016-01-06 10:48 EST

  None (edit)
Comment 3 JBoss JIRA Server 2013-10-24 19:18:22 EDT
Mark Drilling <mdrilling@redhat.com> made a comment on jira TEIIDDES-1897

I did some debugging - this is actually an issue with the AdminAPI getDataSourceNames() method.  It is returning the pool name rather than the jndi name.  I never noticed before because I was using same names.
Comment 5 JBoss JIRA Server 2013-12-05 15:51:38 EST
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-2712 to Closed
Comment 6 belong 2013-12-09 19:50:42 EST
Assuming this will be set to VERIFIED before GA - setting requires_doc_text- accordingly.
Comment 7 Lucie Fabrikova 2014-02-04 08:16:16 EST
In dialog "Import using a Teiid Connection", the section Data Sources still shows the pool names of datasources in column "DataSource" (in Teiid Designer 8.3.1.Final - JBDSIS-7.0.0.GA-GA).
Comment 9 jolee 2014-04-09 12:17:52 EDT
https://github.com/Teiid-Designer/teiid-designer/pull/322 merged onto:
git@github.com:Teiid-Designer/teiid-designer.git   8.3.x

commit a24867c267fdcf6b3957528d172eb2cb1f9c5e33
Merge: eff7d20 61308bf
Author: Barry LaFond <blafond@redhat.com>
Date:   Wed Apr 9 11:14:56 2014 -0500

    Merge pull request #322 from johnathonlee/8.3.x
    
    (BZ1023216) TEIIDDES-1901 Added datasource JNDI name to TeiidConnection ...
Comment 10 Andrej Podhradsky 2014-07-02 02:25:37 EDT
Verified with JBDS-IS 7.0.2.GA
Comment 11 Andrej Podhradsky 2014-07-02 02:26:41 EDT
Created attachment 913993 [details]
How it looks in JBDS-IS 7.0.2.GA
Comment 13 Andrej Podhradsky 2016-01-06 06:59:31 EST
Fixed and included in the latest release.

Note You need to log in before you can comment on or make changes to this bug.