Bug 1023253 - Moving a windows application window is not seamless to or from a display that full-screen.
Moving a windows application window is not seamless to or from a display that...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
:
Depends On: 1008594 1109400
Blocks: 1009648
  Show dependency treegraph
 
Reported: 2013-10-24 22:51 EDT by CongDong
Modified: 2015-03-05 08:38 EST (History)
13 users (show)

See Also:
Fixed In Version: virt-viewer-0.6.0-1.el7
Doc Type: Bug Fix
Doc Text:
Cause: Resizing a monitor caused all displays to be reconfigured but used stale position information to align them Consequence: Sometimes a display that was to the left of another display unexpectedly moved to the right of the other display Fix: Always use current position of displays to determine alignment. Result: Displays no longer jump around unexpectedly when a window is resized.
Story Points: ---
Clone Of: 1008594
Environment:
Last Closed: 2015-03-05 08:38:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Marc-Andre Lureau 2014-07-02 11:46:44 EDT
Bill, you closed the original bug. This one was opened as duplicate for rhel7. Why was the original bug closed? Is it working with rhel7 too?
Comment 4 Jonathon Jongsma 2014-07-03 16:16:49 EDT
This bug should be fixed by the change that moved display alignment from spice-gtk to virt-viewer.  So it should be fixed by the rebase to 0.6.0
Comment 6 CongDong 2014-07-22 21:44:23 EDT
I can reproduce with: virt-viewer-0.5.7-2.el7.x86_64

VERIFY with: virt-viewer-0.6.0-1.el7.x86_64

Steps:
1. Install a SPICE VM and open with virt-viewer
# virt-viewer $vm
2. Have both display configured for 1024x768.
3. Put 2nd display in full-screen.
4. Open an app in the guest, and move the window from one display to another.


Result:
Movement is uninterrupted from one display to another
As the result, set VERIFIED
Comment 8 errata-xmlrpc 2015-03-05 08:38:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0295.html

Note You need to log in before you can comment on or make changes to this bug.