Bug 1023263 - Anaconda fails to select default app groups for selected DE
Anaconda fails to select default app groups for selected DE
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F20BetaFreezeException
  Show dependency treegraph
 
Reported: 2013-10-24 23:35 EDT by Mike Ruckman
Modified: 2014-01-30 17:14 EST (History)
9 users (show)

See Also:
Fixed In Version: anaconda-20.25.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-30 17:14:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.ifcfg.log (1.45 KB, text/plain)
2013-10-25 19:18 EDT, Mike Ruckman
no flags Details
anaconda.journal.log (640.61 KB, text/x-vhdl)
2013-10-25 19:19 EDT, Mike Ruckman
no flags Details
anaconda.log (13.31 KB, text/plain)
2013-10-25 19:19 EDT, Mike Ruckman
no flags Details
anaconda.packaging.log (1006.26 KB, text/plain)
2013-10-25 19:21 EDT, Mike Ruckman
no flags Details
anaconda.program.log (55.98 KB, text/plain)
2013-10-25 19:21 EDT, Mike Ruckman
no flags Details
anaconda.storage.log (171.68 KB, text/plain)
2013-10-25 19:22 EDT, Mike Ruckman
no flags Details
anaconda.xlog (37.48 KB, text/plain)
2013-10-25 19:22 EDT, Mike Ruckman
no flags Details
syslog (128.97 KB, text/plain)
2013-10-25 19:24 EDT, Mike Ruckman
no flags Details

  None (edit)
Description Mike Ruckman 2013-10-24 23:35:03 EDT
Description of problem:
Anaconda fails to select "Applications for the Xfce Desktop" and "Multimedia support for Xfce" when the "Xfce Desktop" base environment is selected.

Version-Release number of selected component (if applicable):
Fedora 20 Comps (https://git.fedorahosted.org/cgit/comps.git/tree/comps-f20.xml.in)

How reproducible:
Always

Steps to Reproduce:
1. Install F20 from i686 TC5 DVD. 
2. Select defaults.
3. Click "Software Selection"
4. Select Xcfe in "Base Environment"
4.a Note: Nothing is selected in "Add-Ons for Selected Environment"
5. Continue installation
6. Boot freshly installed system.

Actual results:
Xfce apps are not installed (Midori, for example)

Expected results:
Xfce apps should be installed.

Additional info:
The install does complete and is functional.
Comment 1 Fedora Blocker Bugs Application 2013-10-25 12:38:32 EDT
Proposed as a Freeze Exception for 20-alpha by Fedora user roshi using the blocker tracking app because:

 Proposing as a FreezeException for F20 Beta. Currently the installer is not automatically selecting the additional groups marked as default in comps. While this can be fixed by someone paying attention during installation or post-install, it should work out of the box.
Comment 2 Bill Nottingham 2013-10-25 16:26:28 EDT
Moving to anaconda - the data in comps looks correct.
Comment 3 David Shea 2013-10-25 16:51:01 EDT
Please attach the logs from the installation (in /var/log/anaconda on the installed system). "Applications for the Xfce Desktop" should be selected by default. Are you using a kickstart file?
Comment 4 Mike Ruckman 2013-10-25 19:18:01 EDT
Created attachment 816310 [details]
anaconda.ifcfg.log
Comment 5 Mike Ruckman 2013-10-25 19:19:03 EDT
Created attachment 816311 [details]
anaconda.journal.log
Comment 6 Mike Ruckman 2013-10-25 19:19:58 EDT
Created attachment 816312 [details]
anaconda.log
Comment 7 Mike Ruckman 2013-10-25 19:21:03 EDT
Created attachment 816313 [details]
anaconda.packaging.log
Comment 8 Mike Ruckman 2013-10-25 19:21:47 EDT
Created attachment 816314 [details]
anaconda.program.log
Comment 9 Mike Ruckman 2013-10-25 19:22:24 EDT
Created attachment 816315 [details]
anaconda.storage.log
Comment 10 Mike Ruckman 2013-10-25 19:22:59 EDT
Created attachment 816316 [details]
anaconda.xlog
Comment 11 Mike Ruckman 2013-10-25 19:24:13 EDT
Created attachment 816317 [details]
syslog
Comment 12 Mike Ruckman 2013-10-25 19:27:56 EDT
I've attached all the logs from the /var/log/anaconda directory. Three files, (ks-script-5Kwbll.log, ks-script-hcs8m5.log, ks-script-WDaWkX.log) were all empty - so they weren't uploaded. 

This was from the TC5 DVD image. I've gotten the same results with both iso to USB from dd and iso to USB from livecd tools.

Let me know if there's anything else you need.
Comment 13 Mike Ruckman 2013-10-28 13:11:04 EDT
Discussed in 2013-10-28 Blocker Review meeting [1]. Voted an AcceptedFreezeException. This would be a release blocking bug for a primary DE but not for a secondary DE. A tested fix would be considered past freeze.

[1] http://meetbot.fedoraproject.org/meetbot/meetbot/fedora-blocker-review/2013-10-28/
Comment 14 David Shea 2013-11-01 11:28:24 EDT
Fix pushed to master as e98272891b0c6565b5fc9207aefc602cbba393a0. I'll hold off on pushing it to f20-branch since this bug doesn't have the magic words for beta.
Comment 15 Adam Williamson 2013-11-06 13:12:35 EST
David: er, it did - it was marked as an acceptedfreezeexception as of comment #13 above. But a bit late now, maybe?
Comment 16 satellitgo 2013-11-22 11:57:07 EST
seen in default f20 LXDE netinstall and DVD x86_64in Beta TC-2 install
no internet group in menu 
 Release notes launch javascript looking for Netscape...
 Preferred Applications browser and mail client are empty
no browser or mail
Comment 17 Mike Ruckman 2013-11-22 13:32:47 EST
The initial reproducer of this bug seems to be fixed. What's found in comps [1] is reflected in anaconda. The issue in Comment 16 doesn't seem to be the same - because there's no groups set in comps as default="true" like there is in Xfce.

[1] https://git.fedorahosted.org/cgit/comps.git/tree/comps-f20.xml.in#n6239

Note You need to log in before you can comment on or make changes to this bug.