Bug 1023284 - Anaconda should partition the default /boot partition based on the boot loader specification
Anaconda should partition the default /boot partition based on the boot loade...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 02:09 EDT by Jóhann B. Guðmundsson
Modified: 2014-02-21 12:39 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-21 12:39:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2013-10-25 02:09:19 EDT
Description of problem:

Anaconda should follow the partitioning layout for the boot specification for the /boot partition on (u)efi installs so alternative boot loaders such as gummiboot as well as kernel updates can work without a hitch. 

http://www.freedesktop.org/wiki/Specifications/BootLoaderSpec/
http://freedesktop.org/wiki/Software/gummiboot/
http://www.freedesktop.org/software/systemd/man/kernel-install.html


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Frank Ansari 2013-12-24 13:37:27 EST
The partition tool of anaconda is for me like some adventure. You specify your layout and come back to the parent page. There you see that your layout is wrong (there is an error) but you get no hint what is wrong (this was the same thing in the last versions). I hoped it would have improved for Fedora 20 but nothing. I was disappointed and it took me the whole afternoon to setup my system the way I wanted it.

First you have to find out that anaconda insists on a separate /boot/efi partition. This could be avoided - and this is what I tried - by simply formatting /boot with vfat. But as soon as /boot/efi is missing you get an error. But you get no explanation from anaconda that the reason for the error is that /boot/efi is missing. This you have to find out with trial and error.

Now the next surprise: even if you give the /boot/efi partition to anaconda and you try to format /boot with vfat to be prepared to install gummiboot: then anaconda is giving you again an error. Then you change to ext4 for /boot and then it works.

In the end I installed the system anaconda wanted it to have and then used a chroot environment and gdisk to remove the /boot/efi and reformat the /boot partition with vfat in order to work with gummiboot.

Handling something like this is very straight forward with Arch Linux but pain in the ass with Fedora.
Comment 2 David Shea 2014-02-21 12:39:08 EST
(In reply to Jóhann B. Guðmundsson from comment #0)
> Description of problem:
> 
> Anaconda should follow the partitioning layout for the boot specification
> for the /boot partition on (u)efi installs so alternative boot loaders such
> as gummiboot as well as kernel updates can work without a hitch. 
> 
> http://www.freedesktop.org/wiki/Specifications/BootLoaderSpec/

Conspicuously absent from this spec: anything about secureboot and how this spec is supposed to work with a shim-loaded bootloader.


> http://www.freedesktop.org/software/systemd/man/kernel-install.html

No thanks, we already have one of those

Note You need to log in before you can comment on or make changes to this bug.