Bug 1023286 - authconfig doesn't set IPADOMAINJOINED to yes after successful join to ipa domain
authconfig doesn't set IPADOMAINJOINED to yes after successful join to ipa do...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: authconfig (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Tomas Mraz
David Spurek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 02:15 EDT by David Spurek
Modified: 2015-03-02 00:28 EST (History)
4 users (show)

See Also:
Fixed In Version: authconfig-6.1.12-14.el6
Doc Type: Bug Fix
Doc Text:
No doc text needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:44:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Spurek 2013-10-25 02:15:37 EDT
Description of problem:
authconfig doesn't set IPADOMAINJOINED to yes after successful join to ipa domain

 authconfig --enableipav2 --ipav2domain=ipa.baseos.qe --ipav2server=sec-ipa1.ipa.baseos.qe --ipav2realm=IPA.BASEOS.QE --ipav2join=admin --update
[/usr/sbin/ipa-client-install --noac --domain=ipa.baseos.qe --server=sec-ipa1.ipa.baseos.qe --realm=IPA.BASEOS.QE --principal=admin  ]
Autodiscovery of servers for failover cannot work with this configuration.
If you proceed with the installation, services will be configured to always access the discovered server for all operations and will not fail over to other servers in case of failure.
Proceed with fixed values and no DNS discovery? [no]: yes
Hostname: hp-sl390s-01.rhts.eng.bos.redhat.com
Realm: IPA.BASEOS.QE
DNS Domain: ipa.baseos.qe
IPA Server: sec-ipa1.ipa.baseos.qe
BaseDN: dc=ipa,dc=baseos,dc=qe

Continue to configure the system with these values? [no]: yes
Synchronizing time with KDC...
Unable to sync time with IPA NTP server, assuming the time is in sync. Please check that 123 UDP port is opened.
Password for admin@IPA.BASEOS.QE: 
Enrolled in IPA realm IPA.BASEOS.QE
Created /etc/ipa/default.conf
New SSSD config will be created
Configured /etc/sssd/sssd.conf
Configured /etc/krb5.conf for IPA realm IPA.BASEOS.QE
trying https://sec-ipa1.ipa.baseos.qe/ipa/xml
Adding SSH public key from /etc/ssh/ssh_host_dsa_key.pub
Adding SSH public key from /etc/ssh/ssh_host_rsa_key.pub
Forwarding 'host_mod' to server u'https://sec-ipa1.ipa.baseos.qe/ipa/xml'
Could not update DNS SSHFP records.
NTP enabled
Configured /etc/ssh/ssh_config
Configured /etc/ssh/sshd_config
Client configuration complete.


[test]cat /etc/sysconfig/authconfig | grep IPADOMAINJOINED
IPADOMAINJOINED=no

Version-Release number of selected component (if applicable):


How reproducible:
authconfig-6.1.12-13.el6

Steps to Reproduce:
1. authconfig --enableipav2 --ipav2domain=<domain> --ipav2server=<domain server> --ipav2realm=<realm> --ipav2join=<user used to join> --update
2.cat /etc/sysconfig/authconfig | grep IPADOMAINJOINED
3.

Actual results:
IPADOMAINJOINED=no

Expected results:
IPADOMAINJOINED=yes

Additional info:
Comment 5 errata-xmlrpc 2014-10-14 03:44:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1558.html

Note You need to log in before you can comment on or make changes to this bug.