Bug 1023289 - [RHSC] When multiple hosts of the same cluster are selected for removal, show an appropriate error message.
[RHSC] When multiple hosts of the same cluster are selected for removal, show...
Status: CLOSED DUPLICATE of bug 1024997
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
low Severity medium
: ---
: RHGS 2.1.2
Assigned To: Ramesh N
Shruti Sampat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 02:19 EDT by Shruti Sampat
Modified: 2015-05-13 12:33 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 06:01:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shruti Sampat 2013-10-25 02:19:50 EDT
Description of problem:
-----------------------
When the user tries to remove multiple hosts from a cluster at once, the action fails.

For e.g., when the user tries to remove host2, host3, and host4 from a cluster, the following message is seen - 

Error while executing action:

host3:

    Cannot remove Host. Related operation is currently in progress. Please try again later.

host4:

    Cannot remove Host. Related operation is currently in progress. Please try again later.

host2 is removed, but host3 and host4 are not. 

The error message shown should  better convey the reason for failure to remove host3 and host4.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.2-0.21.beta1.el6_4 

How reproducible:
Always

Steps to Reproduce:
1. Add 4 nodes to a cluster and move 3 of them to Maintenance.
2. Select the 3 nodes moved to Maintenance and click on Remove.

Actual results:
The above described error is seen.

Expected results:
Error message should better convey the reason for failure to remove multiple hosts from the same cluster.

Additional info:
Comment 2 Dusmant 2013-11-12 11:49:26 EST
Only if time permits, we will try to fix this. Otherwise, we will drop it out of Corbett
Comment 3 Ramesh N 2013-11-20 06:01:17 EST

*** This bug has been marked as a duplicate of bug 1024997 ***

Note You need to log in before you can comment on or make changes to this bug.